Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
I drove to my friends house then i turned off the car for about 2 minutes, with about half a tank of fuel left. when i restarted my car my needle was at empty low fuel warning was on and check engine light came on. i know this might happen if the gas cap isn't fully tightened, so i turned off my car to tighten it with no success. turned my car on and same problem. but after driving for 30 seconds got my gas back! but engine light remained lit for about 2 hours of driving. i know its pretty vague but any help would be appreciated.

Many Thanks
 

·
Registered
Joined
·
40 Posts
I drove to my friends house then i turned off the car for about 2 minutes, with about half a tank of fuel left. when i restarted my car my needle was at empty low fuel warning was on and check engine light came on. i know this might happen if the gas cap isn't fully tightened, so i turned off my car to tighten it with no success. turned my car on and same problem. but after driving for 30 seconds got my gas back! but engine light remained lit for about 2 hours of driving. i know its pretty vague but any help would be appreciated.

Many Thanks
You might have to drive some more before the light goes off. Give it one to two days for it to go off (if it was the gas cap)
 

·
Registered
Joined
·
208 Posts
Gas cap won't make your gauge read empty it'll only throw a code. I'd say your fuel level bobber in the tank is going bad. Go to auto zone and borrow their code reader.
 

·
Registered
Joined
·
25 Posts
Have the same problem in my 2005 Balt.It has been like that for over a year.Gauge goes from up to full down to empty.Also the gas cap light comes on.Changed the fuel pump assembly and gas cap and still does it.Once this Balt hit 80,000 miles it has been nothing but trouble.Not a youngster driving it either.The car has never been beat.Fuel pump is wired to run all the time.It lost power to it 3 years ago.Not much help to you, but you have my sympathy on it.
 

·
Registered
Joined
·
273 Posts
sending unit is prob going bad or its a bad wire.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top