Chevy Cobalt Forum banner
Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Have my sportline springs installed couple months ago (oct 07) and couple weeks after I hear clicking/clunking like noise from the front and the rear every time I back up or hit a bump and still is. And When I got my rear sway bar installed (apr 08.) from turbo tech racing I saw that the logo that says sportline from my rear spring was upside down.

My question is shouldn't be the logo right side up?? Asked the mechanic who installed it and he said that just because the logo was upside down it doesn't mean anything:?. And if the springs are indeed upside down, I've driven the car in that condition for quite a while. Do you think I may have damage the springs already and will have more headache if I get the springs put the right way??

Thanks
 

·
Registered
Joined
·
79 Posts
i have the same prob with my springs. i got progress springs.. everytime i back up or hitthe brake or speed bump it.. i hear the same noise...we're in the same boat brotha

sorry i dont have any useful info tho..im waiting for some myself
 

·
Registered
Joined
·
1,538 Posts
they should be mounted one way. they are prolly mounted wrong. have a second shop give you another opinion, get it in writing, then go back to the first shop and complain
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
I asked couple of people around the other site and showed me an instruction manual and it says that all eibach logo should be right side up. I'll try to find another place to get them check up..
 

·
Registered
Joined
·
720 Posts
I just bought some Sportlines. The manual specifically says that they logo needs to be facing up (so that you can read it), otherwise they're mounted wrong. And I know Eibach wouldn't make a mistake on labeling.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #7 ·
ARGH been around couple of shops and they won't accept fixing it!! all I hear ,"we don't do performance stuff" or "we don't do domestic cars". I read somewhere that if the springs wasn't installed right the height of the car wouldn't be even. I looked at my car and it seems pretty ok and the ride is fine except with that little noise and that upside down logo.
 

·
Registered
Joined
·
52 Posts
Springs

Your springs are installed wrong. You should have gone to a shop that knows how to properly install springs. If you are getting a clunking noise, thats bad. You are wearing out the metal to metal parts.
 

·
Registered
Joined
·
1,388 Posts
Damn sorry to hear about this situation you are in man , if it is the rear springs then its really not that hard to fix and you can probably do it yourself if you are mechanically inclined
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #11 ·
Go back to the original shop and raise hell. That works nearly every time.
Sounds like a very good idea but sometimes pissing off a mechanic could F*** your car up even more in purpose IMO.


Your springs are installed wrong. You should have gone to a shop that knows how to properly install springs. If you are getting a clunking noise, thats bad. You are wearing out the metal to metal parts.
Wearing you mean the springs??

Not a lot of shops that works with performance stuff in my area mostly we got here are pepboys and thread quarters and none of them work with performance springs.

Damn sorry to hear about this situation you are in man , if it is the rear springs then its really not that hard to fix and you can probably do it yourself if you are mechanically inclined
Yeah I looked at it and read a sticky how to install springs and the rear are not so difficult to do but I don't have access to any tools and not really mechanically inclined like you said. But a friend of mine will try to work on it tomorrow and he has more experience in cars than me so let's just have our finger crossed.
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top