Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 20 of 41 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Recently me and my friend made a custom intake for my 07 cobalt ls. We took a aluminum tube and removed the stock air box, then we drilled a hole for the MAP sensor and it fit perfectly. I mean like PERFECT, and the only thing we did wrong was the sensor was upside down... But after that the check engine light was on and stayed on. Is this a major problem or should I ignore it because it seems to run fine and no lose of power or anything. Before we tested it to see of it fit we started it cold air intake no sensor and no check engine light. Now with the sensor, check engine light is on?

---------- Post added at 11:54 PM ---------- Previous post was at 11:45 PM ----------

Sorry not map sensor. IAT sensor or whatever it's called
 

·
Premium Member
Joined
·
3,860 Posts
Interesting. The car will run very poorly and stall without the MAF sensor, because the ECM has no idea how much air is coming in and thus cannot maintain a 14.7:1 air/fuel mixture. If you've got a code, check if there are any air leaks in your system between the sensor and the throttle body. Also, check to see if you MAF or filter is dirty, as these can also code. Good luck.
 

·
Registered
Joined
·
6 Posts
That's the thing, the car runs perfectly. Almost better, because It can actually breath. The sensor should not be dirty. We were very carful when handling it but it could possibly be. No air leaks though and filter is clean

---------- Post added at 11:22 AM ---------- Previous post was at 10:39 AM ----------

PROBLEM SOLVED: the MAF sensor was upside down... FAIL. But hey I'm 16 and I'm pretty hyped I made a custom intake haha so all is good. Thanks for your help guys
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
I'm not very familiar with posting pictures because I don't wanna make a photobucket but if you follow me on Instagram I have a few pictures. My Instagram is the same as my username. Anyways we just drilled about 4 holes next to each other the size of the sensor and filed the ends down and it fit perfect
 

·
Registered
Joined
·
1,420 Posts
Is the problem figured out? I only ask because you said it was solved due to the MAF sensor being upside down. But you also mentioned it being upside down in the first post.

If so, great! If not, disconnect your neg. battery. You may need to clear the original code.
 

·
Registered
Joined
·
2,204 Posts
"Custom" intakes usually mean some half assed hack job involving some DIY pipe from autozone. Good luck.
So what...some hack job, half asses ghetto rigged intake that cost no more than $50~ will do the same thing a $250 K&N does...so he's the smart guy...he saved himself a couple hundred bucks.
 

·
Premium Member
Joined
·
2,635 Posts
two hundred bucks to be exact
 

·
Registered
Joined
·
1,067 Posts
lol ^
 

·
Registered
Joined
·
1,067 Posts
two is a couple, yes.
 

·
Registered
Joined
·
1,067 Posts
it's only like 8:30 AM... sheesh.


Bluegtp91, my damn intake tube keeps coming off my airbox.
I have the hose clamp as even and as tight as possible..
what can i do
 

·
Premium Member
Joined
·
2,635 Posts
nooooo not today, but some people do mean more than 2 by a couple just not you :wine
 

·
Levee
Joined
·
3,210 Posts
2 is a couple (thus why when people talk about other in relationships they are like, "oh they make a cute COUPLE") lol.

more than 2 is a few lol
 
1 - 20 of 41 Posts
Status
Not open for further replies.
Top