Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter #1
This seemed like it would be the only place to post it.
It seems like every time I turn around I have to replace bulbs, especially my back-up lights and my brake....
does anyone else seem to be constantly changing out bulbs? Or does my balt just have a bad wiring issue.
 

·
Registered
Joined
·
1,036 Posts
Yes, check for moisture in the housing, one of the number one problems with our headlights, happened to me twice. But other than that no clue.
 

·
Registered
Joined
·
441 Posts
speaking of that maybe i should go check mine i got no problems but it was so cold today my windows were all frozen and frosty took a minute to get em un thwaed and scarped off but with all the water runing down and off my car wont hurt to check
 

·
Not justice...Punishment
Joined
·
3,829 Posts
I'm at 60,000 on my 08 and never replaced a single bulb anywhere. You might, if you bought the car used, want to look at the fuse box and make sure all the fuses are the correct numbers.

Slim chance, but just a thought.
 

·
Registered
Joined
·
127 Posts
No problems here... I replaced all the bulbs in the rear with LED's at about 40,000km but never had a problem with the OE's from 0km's to 40K. Hope you can get it sorted... what a pain in the ass.
 

·
Registered
Joined
·
179 Posts
Discussion Starter #8
I haven't had that problem. Do you have moisture in any of the housings? That could be causing them to burn-out too.
no moisture, but the idea with a different size fuse, ( because it was bought used) makes sense, thanks everyone!
 

·
Registered
Joined
·
911 Posts
Mine's a 07 and I haven't replaced a bulb yet, except for putting h.i.ds in 2 years ago...my rightside headlight has condensation in it tho, but I'm getting gen1 projectors soon so I'm not worried
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top