Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1 (Edited)
Car said engine power reduced then after 1000ft it says engine power disabled. Popped started it and it sounds like it was constantly back firing. The check engine light disappeared after the pop start so when I put it on the computer I got zero codes. I've got gas, brand new plugs I am not sure how to test the spark with the coil pack. The timing chain is not broken but a mechanic friend think it jumped and is now out of time since I am building zero pressure in all but one cylinder where I am getting only 25lbs. You think he is right? It does crank and the throttle body does open when trying to start.

2005 2.2 manual.

Thanks guys!
 

·
Registered
Joined
·
4,647 Posts
Check your oil to see if any gas is in there also. If not, that rules out your rings. But as james said, you probably jumped timing. I would pull your valve cover and push on all rockers to make sure they don't move. If they seem fine, I would buy a new timing kit and see what that does for you

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Check your oil to see if any gas is in there also. If not, that rules out your rings. But as james said, you probably jumped timing. I would pull your valve cover and push on all rockers to make sure they don't move. If they seem fine, I would buy a new timing kit and see what that does for you

Sent from AutoGuide.com Free App
Yea I'll be checking that today. When I pulled the valve cover off yesterday everything looked good. Checking and the rockers and valves today
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top