Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
i've been having problems with my 2005 cobalt (75K) going haywire on me. every once in awhile when im driving the the warning lights and gauges start going crazy, the engine feels like its going to stall when i come to a stop, & the transmission shifts hard. the first time it happened i thought it was a fluke so i forgot about it but now it happens 1-2 times a week. last time i took it to autozone to run a diagnostic but they couldnt check it and told me that the "computers" go bad on these cars. i have read that it could be the ignition control module. im on a tight budget so im trying to keep it away from the dealership (and their $80 diagnostic charge) as long as possible, and maybe fix it myself if i can. any help would be greatly appreciated.
 

·
Super Moderator
Joined
·
11,821 Posts
I will research the exact location. But there is a ground wire underhood on the driver's side that can get loose or corrode provoking these symptoms. There is a thread on here with a guy with similar problem. I think it is under where the fuse block is or coolant container.
 

·
Registered
Joined
·
311 Posts
I will research the exact location. But there is a ground wire underhood on the driver's side that can get loose or corrode provoking these symptoms. There is a thread on here with a guy with similar problem. I think it is under where the fuse block is or coolant container.
Coby...I hope you're still around when my Cobalt gets old and needs a doctor. :laugh: :laugh:
 

·
Super Moderator
Joined
·
11,821 Posts
Hopefully yours will be trouble free.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top