Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
Good morning everyone,
Lately I've noticed that if my cobalt sits for less than a day, upon start up it wont fire up right away. Should the car sit for a few days, it'll start hard followed by a rough idle for 15-30 seconds and then smooth out. If i hit the accelerator as to pass someone, there is a delay in response. Fuel economy (going by the digital readout) is a constant 23.7 mpg (which shouldn't it fluctuate depending on acceleration?)
Car is a 2006 Cobalt with a 2.4 automatic with 124,000 miles, all stock with the exception of K&N CAI and ZZP 2.5" catted downpipe. No codes. I've added the downpipe hoping to allow it to breathe easier. I also switched the CAI back to stock hoping to increase the fuel economy with no luck. Fuel economy has been lousy for close to a year now. OBD scanner shows that the MAF and MAP are functioning well. Could the fuel pump be on its way out?
Thank you,
Jason
 

·
Registered
Joined
·
496 Posts
It could be, I would expect another 5-8mpg anyway out on the highway. How many 100-200 mile hiway runs have you run and where?

You might try a deticated 2hr highway run to see what your getting. Top your tank off till you can't get any more in, run it, then fill it back up. The same way. The longer the run, the more accurate it will be.

And keep your foot out of the SuperCharger.
BTW, when did you check your plugs & Coils? And O2 sensors.....a lasy O2 will eat extra gas.
 

·
Registered
Joined
·
50 Posts
Discussion Starter #3
I will give the road trip a try. Plugs, coils and O2 sensors have been changed out within the last year or so.
Lol, I only WISH I had a supercharger. But then again, if I had one, then I'd really be screaming about the gas mileage! As far as fuel pressure goes, what is the ideal PSI at idle and WOT? I'm planning to rent one from Auto Zone to check that as well.
 

·
Registered
Joined
·
50 Posts
Discussion Starter #4
OK I FINALLY got around to doing a fuel pressure test.
Key on engine off 40 PSI
Idle 59 PSI
2000 RPM 59 PSI
Engine off dropped to 45 PSI
10 min later, dropped to 28 PSI
20 min later, dropped to 20 PSI
From what I've been told pressure should hold steady for a lot longer than that. I don't notice any leaks by the tank or the engine. I even pulled the oil cap and didn't notice any gas smell. At a loss here...
 

·
Registered
Joined
·
3,127 Posts
A lot of older vehicles allow fuel to run back. Just prime the key once before starting it if you think it's that. I had basically the exact same thing on a previous car but that was a 3.8L v6. Went 5 years with the car and 3 of which it did this. With that car it was the crank sensor, only found out because I knew the guy I sold it to and the sensor finally failed completely. Was never a code for it when I owned it but as soon as it was changed that car would fire up with half a crank.
 

·
Super Moderator
Joined
·
11,821 Posts
I'm leaning towards a corroded fuel line like these are notorious for. Do you smell gas at any time? Look at the top of the tank and I bet you'll find a little pool of gasoline. You won't see it on the floor because it pools on top of the tank and evaporates. This would explain your low fuel mileage. There was a recall on this and GM might still cover this if you're in the lower states. Would also explain the hard start after sitting. Rough idle at start-up is caused by air in the fuel line.
 

·
Registered
Joined
·
1,522 Posts
A lot of older vehicles allow fuel to run back. Just prime the key once before starting it if you think it's that. I had basically the exact same thing on a previous car but that was a 3.8L v6. Went 5 years with the car and 3 of which it did this. With that car it was the crank sensor, only found out because I knew the guy I sold it to and the sensor finally failed completely. Was never a code for it when I owned it but as soon as it was changed that car would fire up with half a crank.
One of my old Durangos did that too, I would have to turn the key on and off twice to prime it. It was the check valve in the pump that was bad, but it would always start after priming it and wouldn't have any problems getting fuel. I wasn't about to change the pump on that thing though haha
 

·
Registered
Joined
·
50 Posts
Discussion Starter #8
You were right Coby! I noticed a fuel odor when I got home last night. I popped the hood to see if it might be the injectors leaking, but didn't smell fuel. Crawled underneath the back of the car and could smell fuel. I saw a small spot on the concrete just in front of the rear wheel. The fuel line was corroded, which has me slapping myself because two years ago the EXACT thing happened to my daughter's Saturn Ion. Her car was worse though to the point where it was causing the injectors to click loudly. I'm thinking what happens is that insulating wrap around the fuel line where the line travels up the wheel well traps snow and salt in the winter.
I ordered a fuel filter the other day, so I will change out the fuel lines at the same time.
How often do fuel filters need to be changed? The one on there now has about 25,000 miles on it.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top