Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
575 Posts
Discussion Starter · #1 ·
Well, it's 17 degrees here in great Ohio and what am I doing? Jacking my car up and installing my front trans mount ionsert. 3hrs of painting, dry time, getting it off, then back on later....it's finally on and I'm to frozen to even drive the S.O.B. lol Hopefully it makes even more of a difference with both mounts installed.
 

·
Registered
Joined
·
768 Posts
HAHA! nice. but it's -4 here in minnesota. 17 is now considered thin coat weather. hope allgoes well with the new one. when you gunna hit the road?
 

·
Registered
Joined
·
126 Posts
it's currently 6 degrees here in Troy, OH with a wind chill of -11 Brrrrr!!

06MACobalt added 0 Minutes and 44 Seconds later...

hopefully the mount will make a difference for the frost bite you got putting it on :)
 

·
Registered
Joined
·
314 Posts
i was out installing shit on my truck today too...could only be outside for about 20 mins and had to come back in and warm up...sucks livin in an apt and not having a garage...thats why i cant wait to get a house
 

·
Registered
Joined
·
126 Posts
i was out installing shit on my truck today too...could only be outside for about 20 mins and had to com back in and warm up...sucks livin in an apt and not having a garage...thats why i cant wait to get a house
lol... I live in a condo and still can't get in my garage :D
 

·
Registered
Joined
·
575 Posts
Discussion Starter · #8 ·
haha I had no garage...no crawler....just the nice pavement and a big coat. It sucked but Idc my rear mount holy crap so much better now. Vibes are almost all gone, shifting is perfect and launches are prettty awesome. Worth my time.
 

·
Registered
Joined
·
575 Posts
Discussion Starter · #11 ·
I got all my mounts from Turbotech racing front/lower mounts were 70 w shipping and my upper engine mount was 205w shipping.
 

·
Registered
Joined
·
575 Posts
Discussion Starter · #13 ·
Why did you paint it? don't like the red?
???? I didn't paint anything they are blue mounts. I painted/sanded the aluminum mount not the insert. I painted that black.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top