Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi, new to the scene. Lurked for a while. Not too site savy in general. Live up in Canada - GTA. I have a 2009 Cobalt LT -4 speed automatic. My friend practically gave me his Mom's car with less 50K on it. It was in his garage for a few years.
I'm big on maintenance, so i did everything i could when I got it last year. Tires, flushed fluids, etc. The ride operates like a new car. Could talk about cars all day but this is my first time trying it online.
To be honest I have run into a can't figure out problem - but I understand I should post that elsewhere and will do.
Gotta say some of the pics of personalized rides on here are quite stunning but when I look at my cobalt, its just not the same - clean as hell but stock - lol:grin2:
 

·
Super Moderator
Joined
·
11,821 Posts
 

·
Registered
Joined
·
168 Posts
Photos or it didn't happen! :grin2::grin2:
 

·
Registered
Joined
·
949 Posts
Welcome to the forums!

Nothing wrong with a good clean stock 'balt! They're super reliable daily drivers when you leave them stock and take good care of them!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Well that's what I was hoping. Generally so far so good for the past year. I typically go overboard on maintenance but unfortunately I did have to make a post in the Transmission section for a problem that has me quite stumped. I really thought I would have the car for another decade - not one spot of rust on that body and if you ate a sandwich off the engine block ... its not like your Mom would be yelling at you ... cleaner than alot tables I have eaten off of.

Thankx for the Welcome Parthos.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top