Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Premium Member
Joined
·
2,635 Posts
Discussion Starter #1
OK so I got my 09 LT with 25k miles on it and yesterday when I picked up my friend I parked on a fairly steep hill(parking break on). I got back in the car because I went to the store and I turned it on and the CEL came on. I was scared for a moment but the car was running fine so I continued with life. When I got in my car this morning the CEL light was off I was relieved because I had a 110 mile trip to Hudson NY, made it here fine in my sisters home but then I parked on a really minor hill w/ parking brake and the CEL came back :amazed:....

Drove around because I had to take the fam to Walmart, and when I parked in front my sister home I checked what errors I was getting. I got p0010 and p0010 (I looked up the codes but no idea wth it ment I'm a car noob). Anyways immediately after that my key got stuck in the ignition and the button under the wheel isn't releasing. So me and my bro in law removed the fuse for the engine and disconnected the battery so the car can be off, then we put it all back on to attempt to unstuck the key, and once turned on my engine started stuttering and got the reduced engine power and service traction.... help

Tl;dr = my engine stutters and I got p0010 p0011 codes and can't get key out of ignition, I'm afraid I might be stuck upstate
 

·
Premium Member
Joined
·
3,783 Posts

·
Super Moderator
Joined
·
11,821 Posts
P0010 & 11 are camshaft sensor bank1
 

·
Premium Member
Joined
·
2,635 Posts
Discussion Starter #4 (Edited)
Thanks for the info guys, we got the car back on this morning and everything is fine except the key being stuck on in the ignition, I read somewhere that there's pins that can be pulled when you remove the bottom of the steering wheel to turn the car off, but Idk wth all these things are under this wheel, any help and/or pics?

Nvm it was the green clip I found it.taking it straight to the dealer tomorrow

Sent from my PG86100
 

·
Premium Member
Joined
·
2,635 Posts
Discussion Starter #6
It went great, had to go a little far but they got the job done and I'm picking it up tomorrow, also got a loaner! It was a hhr but its better than nothing. Can't wait to pick up my lovely cobalt
 

·
Super Moderator
Joined
·
11,821 Posts
Did they fix it and what was wrong?
 

·
Premium Member
Joined
·
2,635 Posts
Discussion Starter #8
I'm super late but they replaced the ignition cylinder and my intake actuator, don't know what that is but that was causing my CEL

Sent from my PG86100
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top