Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I did not find anything close to the problem that I am having in the other threads. This is a 2009 cobalt auto that shifts fine most of the time but some times I have hard shifts. I do not have any error codes for the transmission when I have hard shifts. I do not want to cherry pick parts to solve this problem. I have had this cobalt for a short time and it has 108K miles motor runs great accept has p0010 and p0013 codes. I have ordered the camshaft solenoids for the open circuit. Any ideas?
 

·
Super Moderator
Joined
·
11,821 Posts
Do you have a scanner that will read U codes? You mauy have a communication error between BCM and TCM causing the hard shift.
 

·
Registered
Joined
·
1 Posts
I have been having shifting issues with my 2010 lt cobalt. It shifts hard from 1st to second, sometimes 2nd in to 3rd too. When I step on the brake it makes a click sound down by my shifter. I was told I needed a transmission rebuild, $2200 later, the problem didn't get fixed. They took apart my transmission again, and now think it's an electrical short, possibly from when they fixed that recall with the "service airbag" (btw that recall happened because of me)
 

·
Registered
Joined
·
2 Posts
Solution??

Beverly Baker,

I'm having the same issue. Been getting the run around from GM, had it in to them several times. They just keep changing parts. they've changed my TCM, transmission coolers lines, flushed the system. They told me my transmission needed to be replaced. I did that but got it done elsewhere .....twice ...as GM quoted me an absurd amount. surprise surprise, it did not fix the issue. I've dumped almost $4000.00 into this problem with no solution.

Did you ever get your issue fixed? if so what did you do?
 

·
Registered
Joined
·
1 Posts
First post here

I am having the same issue with my 2010 cobalt. It has around 120000 and it shifts hard sometimes while others it doesn't. I was told it might be the TCM but I am unsure. If anyone has fixed this problem it would be great to hear from you.

Thanks.

Edit: I just found this tread. It may be of interest to anyone having shifting issues. I am going to test it out when I get home.

http://www.yourcobalt.com/forums/transmission/91306-hardshifting-p0700-p0842-p1810.html
 

·
Registered
Joined
·
1 Posts
I just fixed my hardshifting problem I've had since getting the car. I tried fuses, resetting the computer, etc. But nothing. I finally saw this video where the guy explains a spot in the wiring for the transmission where it wears through and grounds to parts of the engine. And sure enough when I looked the same exact spot was worn through and rubbing against that spot. So I cleaned it up, wrapped the f*ck out of it with electric tape, and zip tied it away from where it was rubbing. And my hardshifting quit entirely. Here's that video https://youtu.be/LbKxWrj4SSI
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top