Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi, I recently have been having trouble with my driver side headlight. The headlight was not turning on all of a sudden one day. I should note that I've had HID bulbs in the car for about 2 years. I recently switched to aftermarket headlights, which have a harness that make the new housings a separate high and low beam. I also decided to buy new ballasts for my HID low beam just in case that was the issue. The lights were working fine for awhile, my low beam and high beam both working when switched on. Now all of a sudden, my driver side won't light up at all. The LED's in the housing work fine as well as my blinkers, however my low beam and high beam light do not work at all. When I switch them on, the low beam flickers while the high beam tries to simultaneously power on as well. Both continue at a very low brightness until they both shutdown. All other lights work fine, so does my passenger side headlight. Again, I purchased a new ballast thinking this was the issue and it was not. It seems to be the same issue I was having with my original housings. I made sure the connectors on every socket were fine as well as wires. Does anyone have any idea what this could be? To me it sounds like a deep wiring issue with that side of the car and I know I've had wiring issues with Chevy's in the past as well.

TL;DR Headlight tries to power on but shuts down after a few seconds. Problem just started happening out of nowhere.

I'm new to the forum so thank you for any help you guys can give!
 
1 - 1 of 1 Posts
Status
Not open for further replies.
Top