Chevy Cobalt Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I was working on my 2006 Chevy Cobalt LT Coupe, yesterday installing a CD-Player, amp, and sub. I hooked everything up and everything works great and sounds even better. The problem that I have now is for some reason, my dash lights (instrument cluster, a/c controls, and shift knob) stopped working. I thought this maybe was a fuse, so I check the cluster and interior light fuses: both look good and are not blown. My head lights, tail lights, and info digital display, and check engine lights all work fine. I am stumped!

Do you think maybe it may be the metal contacts on the interior light fuse may have spread too far apart, causing them to when a fuse is plugged in, its not getting a good contact with them? If so, how would I test to verify it is or isn't the metal contacts that hold the fuse in the box.

Any input is appreciated. Thanks!
 

·
Registered
Joined
·
455 Posts
it sounds like maybe something got messed up with the dimmer wire when you installed the deck. idk how you could fix it, but try taking out the radio and see if the lights work. if they do, theres a connection that wasnt made right or something. thats just my best guess though. idk what else it could be.
 

·
Banned
Joined
·
1,559 Posts
I had this issue recently. I couldn't figure out what it was, till I was messing with my headlights, and noticed my parking lights weren't going on. Sure enough it was the parking lamp fuse that blew. Check that. If it's blown, replace it and it will fix the problem. :)
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top