Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I recently had a massive soda spillage all over the driver seat/wheel/dashboard. The radio turns on, but no sound comes from any speaker in the car. The blinkers still function but no ticking sound. Just like to know what im going to need to have replaced. thanks in advance

p.s. yes, i do see it as a possibility that the door speaker may be damaged, but then that wouldn't explain why i don't have any sound emitting from any other speaker. so weather the speaker is blown, or the wire harness is dirty, nothing seems to solve the stereo issue. the stereo itself seems to function fine. There's just no sound from any speaker. fuse i should check? please any and all ideas are welcome

-Cory
09 chevy cobalt LS
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Was not a fuse, pretty sure its the head unit itself. wont know until i switch the stereo out and try a different one.
 

·
Registered
Joined
·
3,127 Posts
I don't know if the stock headunits have it or not but the aftermarket decks have a speaker fuse on the back, worth taking a look at.
 

·
Registered
Joined
·
3,127 Posts
oh well, time for a kenwood dvd indash :)
 

·
Registered
Joined
·
87 Posts
^ this! My factory radio was stuck on CD Saturday, and I punched it. Needless to say it didn't fix it and I broke the screen. So I bought an Avic D3 Sunday. Hoping to install it soon. I have sounds but no control over the radio, and it's stuck on CD :/.

My Stepbrother is having the same issue as you in his 08 Sport. No sound, even the blinker noise. everything else seems normal. I have to look at that this upcoming weekend, let us know if you figure it out!
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
My Stepbrother is having the same issue as you in his 08 Sport. No sound, even the blinker noise. everything else seems normal. I have to look at that this upcoming weekend, let us know if you figure it out!
thats what i cant figure out. i bet even if you replace the display it still wont play

---------- Post added at 10:16 AM ---------- Previous post was at 10:16 AM ----------

im about to replace the whole stereo with the same unit this week. love the stock 09 -2010 gm radio.
 

·
Super Moderator
Joined
·
11,821 Posts
If you have the uplevel pioneer radio the amp has a separate fuse from the radio.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #10
<solved> well because i couldnt wait till this week where id have time to pick up a new radio, i used my tech background and opened the radio and checked all the capacitors, looked for burn marks. and i found nothing but soda residue on the pcb mainboard. I wentout and purchased some power wash(link below) and its really a miracle product. i used to clean iphone and ipod motherboards with it all the time at work. Sure as shit, i put it back together after a good power wash and all is fixed. saved me buying a new radio. I just wanted to pass this information down to the next person with a soda/water damaged radio. BUY THIS SHIT! Coat the mainboard in the spray (be fast it air drys very fast) and scrub with a dry toothbrush till residue of the spill is gone. </solved>
-cheers-


Precision Electronics Cleaner - RadioShack.com
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top