Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So a co-worker of mine called and told me he hit a rock in his 05 cobalt 2.2L automatic.

He hit a rock and it bent the tranny oil pan back a little and of coarse lost the fluid in the pan. He continued to drive it after he hit the rock until the car wouldn't move (obviously no pressure from no fluid), and said it started smoking from under the car somewhere, then he had it towed and then I came into play to fix it.

So I replaced his tranny oil pan, pan gasket, filter and bought tranny fluid (dextron VI), filled 10 quarts with car at temp and it leaked out the check plug on the side of the tranny, so assumed all is good.

Go to test drive, here's the trouble now..

Put in drive car in drive and u have to rev it up pretty good to barely move fwd, but will move this in way...will not move at all in reverse, when put down into 1st or 2nd gear (automatic remember) still will not move at all..almost stalls out. Like the parking brake is on.

Fluid is still full, checked the TCM fuses and basically both fuse boxes completely and all is good. The actual TCM doesn't smell burned but doubt an electrical issue would cause the no reverse issue, but something did smoke he said so here I am..

Does it sound like the tranny is shot? Stuck check valve, airlock from losing fluid?

Please help, he's a broke "new" guy.

Thanks guys!
 

·
Registered
Joined
·
227 Posts
Sounds like a shot transmission. Driving it after losing all of the fluid probably killed it. No lubrication=worn down everything.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top