Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
2006 ss/na. Just replaced a new throttle body 3 days ago, because sometime when i changing gear, rev will shoot up to 3000rpm and stay for a while. After changing the TB everything is good for last 2 days. But today a new problem is happening again. Idle is around 1300 when coasting in neutral, it will drop to normal when come to a completely stop. It really annoying, i looked it up but i don't see a solution. Help please.
 

·
Registered
Joined
·
66 Posts
did you get the idle relearned for the new throttle body? depending on how dirty it was and for how long ive encountered issues where ive replaced a throttle body but the ecm cant/wont relearn the new idle so the ecm would need to be replaced. but if you havent gotten the idle relearned you may want to start there
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Yes the new TB was relearned, the weirdest thing is i found when this issue is happening, just press the clutch very slow when braking, which make the engine nearly stalling, forcing the rev stay at idle. Then it would become to normal. Now this idle issue happens randomly like once a week. So i guess this is some electronic problem, cause if it is a mechanical problem, it would not be some time normal some time bad.

---------- Post added at 08:31 PM ---------- Previous post was at 08:31 PM ----------

did you get the idle relearned for the new throttle body? depending on how dirty it was and for how long ive encountered issues where ive replaced a throttle body but the ecm cant/wont relearn the new idle so the ecm would need to be replaced. but if you havent gotten the idle relearned you may want to start there
Yes the new TB was relearned, the weirdest thing is i found when this issue is happening, just press the clutch very slow when braking, which make the engine nearly stalling, forcing the rev stay at idle. Then it would become to normal. Now this idle issue happens randomly like once a week. So i guess this is some electronic problem, cause if it is a mechanical problem, it would not be some time normal some time bad.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top