Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 20 of 36 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
here is my problem:

anytime i have to come to a stop my idle drops to around 500 rpm. it almost seems like the car is going to stall, but then it picks back up to about 750-800 rpm. i notice this a lot when i stop after reversing. once i put the car into drive, it picks up.

anyone have an idea on what this could be. thanks for the help in advance!!
 

·
Registered
Joined
·
33 Posts
sometimes as i idle, or coast, my rpms like to bounce up and down.
im not sure what the cause of this is, but instead of me opening a new topic, ill just post on yours, hopefully someone has an answer for both of us :)
 

·
Registered
Joined
·
127 Posts
Had this problem with mine (except a little worse...she'd actually stall out). It's currently in the shop getting the final fix. :) What kinds of codes (if any) is yours throwing? If they're related to throttle position at all, try cleaning out your throttle body (they sell stuff to do it at Autozone). If that doesn't help, hit up Autozone again and get some Mass Air Flow sensor cleaner and clean your MAF sensor. If THAT doesn't help, I'm guessing that you'll probably need to either A) replace the throttle body, B) replace the coil pack, or C) replace the ECM, depending on what kinds of codes are being thrown.

My hubby cleaned out and later replaced my throttle body (she was throwing the throttle position codes), cleaned my MAF sensor (still stalling after new throttle body), replaced my fuel filter (VERY early on when this problem first started...hubby thought it was just bad gas), AND replaced all 4 spark plugs (threw misfire codes on 2 & 4) trying to get this issue figured out. My mechanic was leaning towards it needing a new ECM, but the latest code thrown on her (intermittent misfires) pointing towards the coil pack. I lucked out and he had a used one that he was able to test it with and sure enough, she's no longer missing. He's cleaning the fuel injectors as I type and is going to drive her around a bit to make sure, but he's 99.9% sure she's good to go. Had the new code that she threw been related to the throttle body, he would've had to replace the ECM. Apparently, my throttle body and coil pack both took a crap at the same time. My hubby was able to fix the one, but was getting tired of just trying "pipe dreams", as he put it, so we caved and took her in.

Also, IF you have an 06, check out the service bulletin and recall section on here. There was a recall on the fuel injectors back in 2007 (I think) that might apply to you and could possibly be the cause of all this.
 

·
Registered
Joined
·
152 Posts
i'm having idle problems too. it bogs down to 4 or 500 and bounces for a few seconds before smoothing out, i had an emissions code but it's since been fixed, i tried cleaning the MAF, it shakes like a jackhammer when coming to a stop, headlights dim, ac or heat dies down a bit and its really annoying, my CAI rattles off the front cross piece when this happens and it's really loud.
 

·
Registered
Joined
·
674 Posts
that damned Ethanol will destroy non flex fuel cars. I almost had my wife's grand am die on her because of the crap clogging up the cat converter. And i'm sure that the stuff isn't doing any good for the injectors and spark plugs either.

My grandfather told me that back when moonshine was being run, gas also had lead in it, and the lead contradicted the bad effects of the ethanol that some people dumped in their tanks when running low.
 

·
Registered
Joined
·
129 Posts
G5Steven - you are making me feel real old, I remember in high school and after 1983-1985 that most gas had lead in it, that is why today it says unleaded. Back in the 80's there was no such thing an unleaded.
 

·
Registered
Joined
·
127 Posts
Good luck with the Seafoam. My mechanic ran that AND Lucas injector cleaner in mine, and the problem is still there! (Almost stalled on me this morning, and I could feel it misfiring whenever the engine was running.) :-(

*EDIT* It WAS better Friday and Sat (picked up car from shop on Fri), but went crap again. Throwing ANOTHER code again. I'm beginning to think that the check engine light is meant to be permanently on or something! (Next step is either new injectors or a new computer, depending on the code it's throwing.)
 

·
Registered
Joined
·
78 Posts
Discussion Starter #12
UPDATE: so, i decided to start cheap with this issue. figured there was no point in spending big if there was only a small issue. so, what i did:

bought some carb/throttle body cleaner
removed the throttle and cleaned the hell out of it.

replaced my spark plugs.


so far, 5 days later, the car is running way smoother and seems good to go.

TB cleaner = $2.55
DENSO spark plugs = 4 X $1.99

total = $10.98
 

·
Registered
Joined
·
21 Posts
I had the same issues. I cleaned the throttle body and now it runs smooth as glass. It was pretty dirty. Used throttle body cleaner and a tooth brush. Wiped it all dry and put it back together.
 

·
Registered
Joined
·
127 Posts
Man, I'm REALLY wishing I had your guys' cars!!! :)

Mine needs new injectors. After less than 35,000 miles since they were replaced in a recall. :(
 

·
Registered
Joined
·
21 Posts
Did you check the Throttle body. Mine was gunked up pretty bad. I changed my plugs at the service interval and the problem was still there. I cleaned it up and the car runs like new.
 
1 - 20 of 36 Posts
Status
Not open for further replies.
Top