Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
594 Posts
Discussion Starter #1
Ok so I installed the shiftplus kit over the weekend,I might say it works really good.The shifting for the automatics are much smoother when it changes gears, but thats when you have it on 2.Even though this kit can be hooked up to a pcm,but there is no diagram on how to do it with the cobalts.The wiring for the transmission had to be spliced,red with black stripes and the light blue wire,then its basicly done when together with the black and red wire for the kit,but you have to run it underneath the gas pedal so the little rubber piece circle has to come off just to run it where the transmission wires are located.You can leave the little box switch laying around,but if you know where to put it at to have it out of your way you can always do fabrication work.I don't know where my camera is at to do videos or take pictures as of yet,but when I find my camera I will post a video.To me it is recommended for automatic cobalt drivers.
 

·
Registered
Joined
·
142 Posts
I have this on order expected to come in on friday, please take some pics of where you spliced the wires so i'll feel better when i install it lol
 

·
Registered
Joined
·
20 Posts
I bought this for my car and got tired of using it. What I do not like with it is if you leave it switched on after a few cycles of shutting the car down and starting it back up, it will eventually start lurching really bad from shifting into D or R from Park.

I got too lazy to shut if off before turning off my car and turning it back on before I started the car again.

If anyone wants to buy it, I have it for sale, lol.
 

·
Registered
Joined
·
594 Posts
Discussion Starter #4 (Edited)
haven't ran into the lurching part yet,but I have heard about it lurching,then again why worry about it if the transmission can handle that type of situation.Also you don't need to turn it on before starting the car,you can turn the setting on while the car is running,but you can't turn it off since the ecu or pcm will not reset unless the car is turned off either way.
 

·
Registered
Joined
·
142 Posts
looks like tranny mounts are next on my list, any recomendations?
 

·
Registered
Joined
·
594 Posts
Discussion Starter #7
the trans can handle 230pounds of torque though that comes from v6 vehicles like pontiacs.It shouldn't even break down at all or feels like it wants to,but I guess if a tranny mount helps then why not
 

·
Registered
Joined
·
1,119 Posts
it wasnt going to actually break or anything but switching from any combination of park, drive neutral etc... the whole car jerked. i dont think it was doing any harm but it was annoying as hell and everyone could hear it standing anround my car. those mounts stiffened everything up and now its as quiet putting it in gear as if it was stock

i ordered them from turbotechracing.com (get 2, front and back) they are definately worth it
 

·
Registered
Joined
·
594 Posts
Discussion Starter #9 (Edited)
yeah I am going to order tranny mounts either way,I wanted to before I ordered the B&M shift+ kit.So far I am not hearing any loud lurching sound,I hear a small sound nothing big as of yet,then again its only been a week since its been installed.if it was installed wrong it wouldn't be shifting smoother now:p.
 

·
Registered
Joined
·
142 Posts
Ok i install this thing and my engine started acting nuts! it had a rough idle in park and even worse in drive, and after about 40secs after i had the car on at stage 2, it smelled like it was running really rich and i could see white smoke coming out of the exhast. i drove around the neighborhood and i could really tell that it was kicking in and it would shift hard going to 1st to 2nd gear, but then a CEL came on! i turned the car off and switch the the Shift+ off and then restarted the car and everything went back to normal and the CEL went away but the white smoke didn't go away for about 2 more miles. I don't know if it's that i installed it wrong or if it's because i have an '07, i post pics tomorrow on my install.

p.s. on the back of the box is lists 70380 ShiftPlus for GM models '93-98" rear wheel drive and 4 wheel drive vehicles. WTF? did i get ripped off?
 

·
Registered
Joined
·
594 Posts
Discussion Starter #11
no you didn't,because I have a 06 vehicle,I called neverenoughauto to make sure on that same situation,he said the shiftplus is universal,also I didn't see that at all,are you sure you grabed the right wiring?I do hope you grab the right wiring though.I haven't seen any problems like that at all,with cel light or anything.That is really strange.
 

·
Registered
Joined
·
142 Posts
yea i did the wiring wrong, i taped into the wires connected to the fuel injectors, i feel like a dumbass, i could have fryed my motor lmao....

but i'm a 100% sure i did it right this time and its a really fun toy, the shifts arn't as harsh as i thought they would be even on stage 2, but i like the way my tires chirp from 1st to 2nd gears. Great mod for autos!
 

·
Registered
Joined
·
594 Posts
Discussion Starter #13 (Edited)
ok good I am glad that you got it this time,best thing about that B&M is where it changes the gears smoothly with no lag.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top