Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 15 of 15 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hey all..So anyway i got a custom intake not much bigger then stock,and still got same IAT adapter being used. My problem is i keep throwing a code says im running lean...w.e...lol...although it sometimes comes up quicker depending on my drivign in these mountains...anywho is there any way to trick or adapt my engine to run more gas.I have had a MAP sensor fault once..would a MAP that allowed more presure work?Thanks all!.kyle
 

·
Registered
Joined
·
1,056 Posts
Some aftermarket intakes throw codes from the MAF sensor, are you running an oiled filter?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #4
it just a crappy tirew filter..might be..i clean my intake regulary..any harm to engine?it runs temp wise perfect..
 

·
Registered
Joined
·
1,056 Posts
when you say you clean your intake regularly what does that entail? Constantly cleaning and re oiling your air filter? if your filter has too much oil then your MAF sensor throws codes because its taking some oil into the manifold.

^ yes pics plz
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7
i mean i ctake off intake and fog engine with intake kleen.ok will post in a lil bit. it goes from filter to tubing with iat,then to a little resevoir like fords have,then direst to the 90 on the TB.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #9
ok here are the pics.dont knock me for them too hard..lol.I am cheep and dont want to buy a true CAI to have same problems..and ill need a diff cai one once i am supered after my fe5 finish coming inL:)

 

·
Registered
Joined
·
31 Posts
Discussion Starter #11
eversince i tookk out the stock piece that covered engine(three days ago)there has been nothing.i added the 90 and the contraption just after 90,and so far so good.just want to know if that looks like a engine damaging thing.lol.it is air tight and think i got it runnign less lean now then it was before.
 

·
Registered
Joined
·
45 Posts
I highly suggest going to a local autoparts store and just buy some spectre modular tubing. I bought all my parts including the MAF adapter kit for about $120. Pic is the intake. Im still waiting for my MAF adapter kit to be shipped in.


UPDATE: my MAF adapter came in and i installed my intake, here it is. About $120 in parts and $10 in tools and i was set. (i didnt have any tools, so anyone with the basics can do it.)
 

·
Registered
Joined
·
31 Posts
Discussion Starter #14
What size tubing did you use? and do you throw any codes?I fint my millege runs 7.0-7.4l/100km is that normal?
 
1 - 15 of 15 Posts
Status
Not open for further replies.
Top