Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
When I first got my 08 Colbalt LS 2.2 litre, I had an issue with starting. I would put the key in, all lights and radio would come on and then lights would go out like normal. I would turn the key and nothing. I would wait 2-3 mins and try again and same thing. After a few times it would eventually start no problem. This issue went away for 3 years and it is now back with a vengeance. It happened last night after work and it has happened again this morning before work. No security light comes on but I have a funny feeling its something to do with my security module.

Any suggestions?
 

·
Registered
Joined
·
5,481 Posts
Check all of your grounds. One of them is probably not making proper contact.
 

·
Levee
Joined
·
3,210 Posts
Try unplugging your battery for 15 minutes then plugging it back in to see weather or not that will help with the fix of your car. A relearn may fix it.

And Welcome btw! :)
 

·
Chevy Customer Service
Joined
·
794 Posts
Welcome to the forum, SPuDS!
Hopefully you're able to resolve this concern with the excellent tips already provided. If you should need to get anything looked into at a dealership, please don't hesitate to contact me as I'm available to assist in whatever ways I can.
Sarah, GM Customer Service
 

·
Super Moderator
Joined
·
11,821 Posts
Sounds like you have a bad ignition switch. Do you have a CEL? because a low battery voltage can also cause your problem and even make it hard to remove the key. Check battery connection to make sure it's clean and tight.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
thanks for all the advice, I'll give it all a whirl and see what happens..

Not sure what the CEL is though..

---------- Post added at 01:45 PM ---------- Previous post was at 01:43 PM ----------

Try unplugging your battery for 15 minutes then plugging it back in to see weather or not that will help with the fix of your car. A relearn may fix it.

And Welcome btw! :)

thanks for the welcome.. I'll try this after checking all my grounds as well..
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top