Chevy Cobalt Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
So I was driving my 2008 cobalt and it just up and lost acceleration and made a loud knocking on the freeway. I tried starting it back up but all I got was the loud knocking and a refusal to even accelerate. I looked under the car and there’s oil all under the passenger side but I can’t figure out where it’s coming from. Added some oil and the knocking got better but it’s still there and still won’t accelerate.
 

·
Registered
Joined
·
24 Posts
So I was driving my 2008 cobalt and it just up and lost acceleration and made a loud knocking on the freeway. I tried starting it back up but all I got was the loud knocking and a refusal to even accelerate. I looked under the car and there’s oil all under the passenger side but I can’t figure out where it’s coming from. Added some oil and the knocking got better but it’s still there and still won’t accelerate.
So I was driving my 2008 cobalt and it just up and lost acceleration and made a loud knocking on the freeway. I tried starting it back up but all I got was the loud knocking and a refusal to even accelerate. I looked under the car and there’s oil all under the passenger side but I can’t figure out where it’s coming from. Added some oil and the knocking got better but it’s still there and still won’t accelerate.
Sorry to tell you. But its more than likey a spun bearing, and you've already grenaded
 

·
Registered
Joined
·
24 Posts
Wow mobile site glitched out. But as I was saying Im sorry to tell you that more than likely you have a spun bearing and already grenaded your engine with metal shavings continuing to run it. I had the same thing happen on the highway ( although I was going 145 in my recently purchased SS/TC) and had the same thing happened . First a burning oil smell, then a loss of power, followed by oil spray all over the passenger wheel well and timing chain cover. Ended up spinning the bearing on #1 cylinder. Which is weird because if i remember correctly thats on the drivers side. Whole engine was scrapped. If you want to find out for yourself, I'd run a compression check on all 4. Depending on your model of Cobalt I believe it varies. Maybe someone else can chime in here and get compression stats. Or you can look them up. regardless it should be obvious if you have lost compression on a cylinder when testing.
 

·
Registered
Joined
·
279 Posts
Unfortunately you probably didn’t know that you should be checking you oil level about once a month.

GM Ecotec engines have a tendency to drink a lot of oil through the PCV system integrated into the valve cover. It’s a poor design. Also you could have had worn piston rings allowing oil consumption. Possibly an oil leak as well, being that these cars are pretty old by now.

The knock you likely heard was the connecting rod bearing letting loose and now will have a hole in the engine block. I have replaced a number of these engines for this exact problem. Because the customer never checks the oil, or not often enough.

For this reason, I check the oil level in my Cobalt every two weeks, or about 500 miles. Mine mainly uses a lot of oil if I have revved the engine high into the rpms, like getting onto the freeway or spirited driving. If I keep the rpms low, like under 4000 rpm, less oil is used up.

You will now need to decided if the car is worth installing a new engine into. I assume you would have to find a mechanic as you may have little to no knowledge or ability to install an engine. Of course if you have an engine lift and other tools needed that would be the cheapest option. You’d need to find an engine that is exactly what’s in the car. They didn’t make little variations in the engines from different years so not everything may be the same. The wrong engine can lead to it never starting once installed as I’ve found out from others experiences.

At a shop expect to spend anywhere from $1800-$3200. Like I said you’ll need to decide if the car is worth spending the money. If it’s in terrible shape already, you’ll be better off looking for a new car. If you’re like me, you’ll do all the work in your own shop and not have to pay anyone.
 

·
Registered
Joined
·
24 Posts
Not sure what your talking about cobalts drinking oil unless its from neglect? My 2.2L never moved on the dipstick. But it was only at 70k miles for the years I owned it. And My SS most likey spun a rod bearing because I found out the previous owner, from someone who knew him. Was notorious for working on cobalts and hand tightening everything. Which also goes hand and hand with straight abuse too i guess. Never had a hole in the block when it spun though. And by the time I got the engine pulled all the oil spray was gone. Guessing it blew out the head gasket. Also the rod bearing had plenty of meat on it. Maybe almost new. Previous owner must of also replaced rod bearings and not torqued them down to spec.
 

·
Registered
Joined
·
279 Posts
Ecotec engines are well known for oil consumption. I’ve seen some that don’t use oil at all. But a lot that do. My friends 2012 Equinox, with 2.4L, would used about a quart every 300 miles, or a full tank of gas. She didn’t listen when I told her it’s a know problem even at the dealerships. The engine didn’t seize up luckily when it did run out of oil. But the transmission went out before that happened. It isn’t the first one I had seen do it.

My ‘06 Cobalt uses a bit of oil. But doesn’t smoke or anything. I know the previous owner didn’t take great care of it though.
 
1 - 6 of 6 Posts
Top