Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 20 of 21 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
So my driver's side Low Beam has some kind of wiring issue. I can wiggle the wires going to it and it will come on if I get it just right, but I'm not sure how to fix this permanently. I guess I could cut some wires and splice some newer ones in, but I'm concerned it's a connection in part of the actual harness that connects to the wires leading to the light or the wiring connection to the low beam itself. Not sure how to check. The other side works just fine, high beam works great too. If I remote lock/unlock my car both lights turn on (not sure if it's high or low beam though) but that low beam just doesn't like me or something.

I'm sure if I take it somewhere it will cost a lot because it's wiring. Any ideas on a DIY fix I can try?
 

·
Registered
Joined
·
71 Posts
i had a similar issue with my stock headlights, behind your headlights has a black "quick connect" so u can disconnect your headlight harness from your cars harness, in my case GM had forgotten to use some silicone sealant and this quick disconnect rusted completely out so i cut it out and wired the headlight directly and everything has been fine since. not sure if this is your issue but my car was doing the exact same thing only it was my passenger side.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
I wonder if I could just buy a simple quick connector and use that after removing the old one?
 

·
Say What again!
Joined
·
6,011 Posts
Should be able to buy the pigtail, yes. If that's the issue.
 

·
Say What again!
Joined
·
6,011 Posts
As long as that's the one that needs to be replaced. Just match the leads to the current one and only replace one lead at a time.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #8
Ok, so I fixed my headlight after trying a lot. I ended up buying a new harness for both male and female sides of the plug. After reconnecting the 2 I found that my headlight was still out. I then decided to check the fuse just for kicks and replaced the hi beam with the low and BAM lights on. So yeah, it was the fuse. I didn't think it was possible since the light was coming on when I turned the alarm on/off.

Now I have a new issue: My dash lights for my MPH/RPM and A/C area don't come on. So at night I can't see anything on my dash except my mileage and my radio. Any idea why this is happening or what would cause it/how to fix it?
 

·
Super Moderator
Joined
·
11,821 Posts
When both tail light bulbs burn out or the circuit is open the BCM turns the instrument panel lights off to let you know you have no taillights.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #10
So I need to look for a BCM fuse then? Taillights are fine. What would cause the Circuit to be open? A guy at Oreily's said it was most likely the dimmer, I really have no idea though.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #11
I check every fuse I could think of and still no luck. I got the dimmer switch which will hopefully fix it...

If there are any other fuses I should try please let me know.

Just for clarification here is my current issue:

The Nighttime Dash lights don't work, the radio works fine, but the backlights for the buttons to change stations don't light up and the backlights on the A/C and Heating below the radio don't light up either. However if I push the defogger (or other similar buttons) that cause a light to come on, then that little light will function normally.
Lastly, the backlights on the shifter (P/R/N/D/2/3) also don't light up.
 

·
Say What again!
Joined
·
6,011 Posts
Shifter does have one.

Sounds like a bad dimmer to me - or related to it, at least.
 

·
Say What again!
Joined
·
6,011 Posts
Yeah - how else would you see what gear you put it into at night without it?
 

·
Registered
Joined
·
949 Posts
Um, counting? lol
3 clicks to drive. Or I guess you could turn on the dome light if you needed to.

Still, if it's not one of those things that Chevy removed, then I kinda want to put an LED in there.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #17
Well I replaced the dimmer and everything is still the same. I did notice that my passenger light doesn't come on when un/locking my car with the remote. It used to though. So is there a fuse for that situation? I just switched around the fuses for hi and low beams on that side and got nowhere.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #18
Ok, got some new info on this over the last day or so.

As I was leaving the house tonight for work my wife called me and said my taillights were out. My brake lights work though. Not sure if my smaller rear light on the side work. My back blinkers work I know.

What fuses should I look at for an 07 Cobalt in this situation?

Fuse Box under Hood

Fuse Box under console

At this point I'm praying it's just a fuse I haven't checked yet. I'll recheck any fuse you guys think could be the issue.
 

·
Super Moderator
Joined
·
11,821 Posts
Remember my post#9? I bet you both bulbs are burnt!!!



 

·
Super Moderator
Joined
·
11,821 Posts
Check if your license plate bulb comes on it's on the same circuit.
 
1 - 20 of 21 Posts
Status
Not open for further replies.
Top