Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 12 of 12 Posts
J

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I went in the ditch the other night after going over a hill and through a snow drift that was only half way through my lane. Got a wrecker to pull me out, walked around the car and everything looked fine. Car was running a little warm but I figured it was cause of poor air through the snow packed radiator.

Next day, i goto drive to town. 15 miles.... The car is getting hot quick. Ok so there is snow in there.... I'll just goto the car wash. By the time i get a mile out of town the overheat idiot light pops on... Temp - about 260F. I get to town and the first place i get to pull in is Autozone... Temp - 305F. Motor is knocking and it shuts down.

My buddy comes out and asks whats wrong, and I tell him what has happened so far. We pop the hood, and the raidator/ac condensor and fans are pushed up tight to the motor and is shapped like a U. There is no coolant in the jug. So that explains everything. He pulled out the dipstick and the Oil was boiling on the stick! But looked ok.... Pulled the oil filler cap off.... Milk-shake looking.

Goto AAA in town, call from there to file my claim. They had a tow truck pick up my car and take it less then a hlf mile down the road to the dealership / body shop. So far the damage is at $1,300 just to get the radiator, a/c condenser, engine fans, and ac charged. Then the tranny pan is dented and there adding that. Next there going to pull the codes on the computer and fix all of those issues. And there is also a bent rim or two as well.....

I know that 2.2L Eco is toasted. No way it could hold up to that heat. So now they got me in a 2010 HHR LT Flex-fuel POS.... Its a dog compared to the cobalt. I know I never posted much, but I though I'd share this and I'll let you know what they do.

Later....
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #3
I stopped by there today and the service manager said they are going to work on it more monday. He said they had to push it in a repair bay cause it won't start.
 

·
Registered
Joined
·
1,218 Posts
Yeah, running it without coolant can kill the engine fairly quick. The cooling system on these cars are about as fragile as Rick DiPietro. A large raccoon can easily destroy the radiator.
 

·
Registered
Joined
·
194 Posts
Rick DiPietro lol.... one bunch, fractured face .... ah that was hilarious, by a penguin no less... wimpiest team out there... then again Johnson is more of a traveller than a penguin....

sorry to hear about the car... usually when they pull a car out a ditch they inspect the entire thing... guess they waved you off too early.
 

·
Registered
Joined
·
1,218 Posts
wimpiest team out there...
Implying we don't have the most penalty minutes in the league right now.



But anyways, back to the topic before we get slapped.

Since the car is a 05 base, the insurance may write it off if it needs a new engine.
 

·
Registered
Joined
·
931 Posts
yehh that motor is gone, 305 is freekin brutal hot, sry dude
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #11
They just informed me the parts should be in today. They said there going to put the radiator and condenser back in it then do a "HOT" test that basically means there going to drive it about 10 miles down the expressway. If they say its alright and done, I'm going to test drive it to see... There is no way there isn't at least a warped head. It was 305F where the sensor was.... on the outer edge of the block.... it had to be hotter else where in the motor.

I could have pulled over and looked at the radiator, but I live in the country and I would have been stranded for hours if I didn't keep going. Cell phone reception can suck big time around here... But I'll be moving soon to Midland, so I won't have to worry about that anymore.
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #12
Got it back about a week ago. They installed a new radiator and new AC condensor and recharged the ac. Also Painted the front bumper. Was about $2,300 and i had a $500.00 deductible to pay cause they said I was at fault. BS! If i would have known it I would have fixed it my self and I would have done it for less than $500.

The motor is running fine and they said there is nothing wrong with it... But its making a weird humming noise now and I have little heat. Engine light is on now, but they said it was on for 16,000 miles before, but i know it wasn't cause I drive it...

I'm just hoping it blows up... I'm sick of the headache and dealing with the ins company.
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top