Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Car first started Out not going into overdrive 5th Gear I think, It was running at 3000 rpm at 60mph , hooked to computer and got code to change solenoid b, so I got a Guy to do that and after picking it up it was Worse than before, jerking and not changing Gears correctly, took it to Chevy dealership and That was a complete joke, after 3 weeks couldn't even get a Call back of what they found wrong, finally After calling owner of dealership I got service department on the phone to tell me they recommend a tranny change and I was told him no way I would come get It, picked it up On That Monday and The paper work said 1-2 solenoid, so I said why didn't u Change that, he said we thought it was valve body causing that and the best solution was a new tranny, I couldn't believe what he was saying, so I drove it 45 miles to another dealership and purchased a new Tcm and they charged me 93 bucks for 5 min work and said it was fine, soon as I pulled out It started same thing, turned around and drove it back, did another scan and was told it was 1-2 solenoid and labor cost was 680 bucks, I laughed and said no way, I've been fighting Cancer for three years and Just don't have the funds at the moment after putting already over 400 , so I went and bought new fluid and filter and took it back to same guy that put in last solenoid, after taking tranny back Apart he found that he didn't hook back up the 1-2 solenoid and at this point I wasn't mad, just happy that I found the problem , drove it around for several hours everything perfect, next morning my wife drove it to work and within a mile Engine light back on changing gears hard, seems to be changing to every gear but overdrive, at this point I'm not sure what is wrong with it, Can't take it back to Chevy dealership cause if u can even find a dealership that will try to fix it, it will cost 25% of the Cars Worth and they don't seem to care or want to even try to look at it, First time I took it in to dealership it sat at same place the whole time To call and say I needed Tranny for almost a month, the tires were even flat and the service guy couldn't even find my car, unreal how they treated us, if anyone has any suggestions on something I could try next, I've tried for 3 months and gotten nowhere but worse. I'm so exhausted with it I have no clue what to do now. Thanks for any info... Mileage on car is 122,000 ,2.2 engine
 

·
Super Moderator
Joined
·
11,821 Posts
Maybe the TCM is losing communication with the BCM. Remove and re-install the 2 blue connectors on the BCM, this should clean them enough to at least see if this is part of the solution. GM techs have the complete trouble shooting procedure they're just too lazy or it would take too long to diagnose and at their rate it would cost too much.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top