Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
594 Posts
Discussion Starter #1
I have a fusion amp that is stuck in protect mode,there is nothing wrong with the fuse its fine.How can I get it out of protect mode which is the red light?
 

·
Registered
Joined
·
1,538 Posts
Burzu, if the red light is on, it could mean you have a bad ground bro.......check your ground wire. Was it working before? if not, check your signal wire as well as your ground wire. What settings was it on(if you said it wasnt working before)? check to make sure all your settings on your amp are zeroed(minimized), and reset the systemby disconnecting all power to it(easiest way is by disconnecting your battery, turn your key on, which drains the system entirely, then shut your key off and reconnect the battery).

If none of the above fixes the issue, take it to an audio shop.
 

·
Registered
Joined
·
594 Posts
Discussion Starter #3
yeah it was working before,when I had music on I was setting it up with some music playing to get the right bass sound you can say,and all of a sudden it went in protect mode.
 

·
Registered
Joined
·
1,538 Posts
yeah it was working before,when I had music on I was setting it up with some music playing to get the right bass sound you can say,and all of a sudden it went in protect mode.
Check all i have listed, then get back to me, ok?

NOTE: You may have also overloaded the fuse for the power wire, check the fuse, and check the rating for both the fuse, and your power wire(gage)..........just in case
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top