Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
992 Posts
Discussion Starter #1
I'm going to try my best to make this short and sweet.

I was driving around last Sunday. Go to start my car and it starts to misfire like crazy. My check engine starts flashing and my AFR gauge goes to 16.8 and doesnt leave it. I manage to wrangle my car down the hill to my house, park and leave it. Go to start it 4 hours later. PERFECTLY FINE. Drive it until today with no problems what soever. Driving around today and bam AFR goes to 17 and it starts misfiring like a champ again. I get it home check my codes and im throwing the P0300-Engine misfire which was quite obvious, but also a whatever code which is INJECTOR #3 something or other.

My question is did my injector just go bad? can it go bad? I had to go to work. when i get home ill pull apart the injectors and such. but what should i look for? its annoying. i just want to get rid of my balt
 

·
Premium Member
Joined
·
2,473 Posts
Yes, injectors can and do go bad. It could be just clogged or totally fried. Anything electonic can go bad, sometimes on a whim.
 

·
Registered
Joined
·
992 Posts
Discussion Starter #3
update. get up this morning start the car let it run 5 minutes perfectly fine. drive it 5 minutes perfectly fine. go to start it two hours later. Service traction comes on and it starts misfiring again.

Ideas guys...shits facked and im pulling 18 hour days right now with no car. i dont have time to rip the whole car apart
 

·
Registered
Joined
·
1,890 Posts
wow thats weird. ummm does the afr go lean only at idle? or while cruising too? if while cruising, do you feel power loss? is it abrupt, does it sputter, explain what happens best you can.
 

·
Registered
Joined
·
992 Posts
Discussion Starter #5
im not driving it, because honestly its un driveable. but yeah when i tried it did it while driving and idling. all the time. the code is p0203 injector 3 control circuit....

and its knocking the engine and its making the whole car shake basically. it gets worse when i put it in gear too? im in the process of taking out the injectors...cleaning and checking and then i dont know what to do

---------- Post added at 09:46 PM ---------- Previous post was at 08:28 PM ----------

sooo uhhhhhhh, yeah the third injector wasnt plugged in all of the sudden...........so im assuming at this moment that was the problem. but now injector one is leaking because the seal broke so i need #42 injectors asap
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top