Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey i kind of need some help i just recently purchased a cobalt from an auction and have been very happy with it. About 2 months ago i got a CEL, and took it to autozone to get the code checked and i was told that it is error P0171, which the clerk said was a up stream oxygen sensor. So today i finally have some extra cash and time to fix the problem and open up the engine compartment and i find that the air intake filter has been moded and quite frankly looks like shit (pics at the bottom). So i have been trying to find some good diy but most of the ones on here pictures wont load so i am not sure if this is a good job or a bad job or i am not sure if i should redo it or not. So i was also wondering if this make shift air intake could be to blame for the code, or if it is really the 02 sensor. And if it is the o2 if someone could point me in the right direction of a diy for replacing the o2 that would be awesome.



 

·
Registered
Joined
·
394 Posts
If you have extra cash, you really should just buy a new intake. I have a custom intake and have seen pictures of others, and this is definitely the most make-shift custom intake i have seen. I wouldn't trust it. It's possible that your sensor is just bad, but I think it's more likely the seal on the intake.
K&N Air Intake 05-07 Cobalt SS - 05-07 Chevrolet Cobalt SS Supercharged
I've had my custom intake for a year now, and I'm about to buy the K&N SRI because I just don't trust my intake to hold up.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks, that was what i was thinking it just looked a little too makeshift.

So i am really no car guy i usually get most of my work done at shops, but seeing as how this vehicle doesnt have a warranty i want to try and start doing stuff myself. So would this makeshift mod be the cause of the CEL or am i going to have to replace the o2 sensor as well.
 

·
Registered
Joined
·
1,316 Posts
been driving with my cel on for over a year. Put a header on and went catless, now the oxygen sensor reads to hot, but it doesnt affect the way the car runs. I'd say if its running good don't mess with it. Short ram looks horrible too, it should throw cel's for being ugly lol
 

·
Registered
Joined
·
394 Posts
There's no way to really know except by testing it, but I would say by the look of that intake it is probably the seal around the MAF sensor. Replacing either part - the MAF sensor or the intake - should be very simple.
 

·
Registered
Joined
·
505 Posts
if you dont want to mess with it now look around for a stock intake and throw that on and see if its still having a CEL. If it is then yes, its your O2 sensor and you might need to replace it pretty quickly.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top