Chevy Cobalt Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Got no power whatsoever im my 2007 cobalt. Only the head lights will power on when battery is hooked up. What could be causing this issue with my cobalt? Any help would be greatly appreciated. Been month trying figure this car out. Oh btw changed motor and tranny on the car and after put other motor And tranny in is when the problem started. Thanks in advance
 

·
Registered
Joined
·
960 Posts
Sounds like wiring. Most likely a ground from the engine harness that was not hooked back up.
 

·
Registered
Joined
·
73 Posts
Just going off of experience here. But a lot of times when doing engine or transmission work the car has likely sat for a good little while. And so many times, for whatever reason, the battery just goes bad. From sitting. Also, a lot of times I have to slow charge the battery for several hours. The lights and everything many still work just fine too.

As mentioned above, the wiring needs to be checked. Grounds can be left off accidentally. The worst thing I’ll see is that someone has assembled an engine and transmission back together and got the wiring stuck between them. Pinched or crushed wiring is not uncommon to see. Especially in cases where someone has rushed a job. The car may run at first, but start to have issues days or weeks after the customer has picked up their vehicle. If this is the case, repairs should be done at no charge. I see lots of things happen from other shops from over the years.
 

·
Registered
Joined
·
960 Posts
Also double check the fuse box. I have seen a few for our Cobalts not get reinstalled 100% correctly.
 
1 - 4 of 4 Posts
Top