Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
5,481 Posts
Discussion Starter #1
I've seen a similar thread but the question was never answered. Mines a 05, no real difference from the OPer
http://www.yourcobalt.com/forums/problems-service/26726-what-normal-idle-2007-5-speed-ls.html

My normal idle (before any modding) was 800 rpm. Now more often than not it idles around 1300rpm. Some times it will go back down to 800 after warming up but recently it will always sit around 1300. I assume this has a negative effect on my mpg which is the main concern. Could it be the intake or header? I plan on tuning this spring so this should get fixed one way or another just want to change it now if I can.
 

·
Registered
Joined
·
1,545 Posts
im fully bolted/tuned and once in a while my rpms will hang around that 1200rpm mark while coasting up to a stop sign or something, but they still normally always drop to the 600-800 mark after 20 seconds for sure. most of the time they dont stay high though, so i in general i cant say i have a high idle issue. i've only noticed this happen to me maybe 5 times since november
 

·
Super Moderator
Joined
·
11,821 Posts
Your intake gasket might be cracked and your sucking air that's bypassing the air-flow sensor. Or make sure you have no air leaks downpath from the "MAF"
 

·
Registered
Joined
·
5,481 Posts
Discussion Starter #4
I'll look but I'm starting to get sick of pulling the wheel well out!! By intake gasket you are referring to the four gaskets on the IM or the one between the IM and TB?
 

·
Super Moderator
Joined
·
11,821 Posts
Either,or but you don't have to take anything apart. If you have a propane torch, start your car, open valve and run nozzle along seems. If you come close to a leak engine will settle down because it will stop sucking oxygen. Did you add a cold air intake? If yes I would check for leaks between throttle body all the way to "MAF" sensor. then head down to gasket between throttle body and intake and so forth.
 

·
Registered
Joined
·
5,481 Posts
Discussion Starter #6
Just an update. I was planning on looking into this this last weekend but noticed all of last week the car never went over 800 rpm while idling! It might be happening only when it's cold out, still think intake leak? And yes I do have a CAI in the same location as the old intake, two weeks ago when I was messing with the headlights and was in there I checked that the cone was still on the piping so it shouldn't be there.
 

·
Registered
Joined
·
41 Posts
06 2.2 ls 5speed and mine idles around 1k here lately on these cold mornings but after it reaches temp it goes back about to 800rpms. Weird though, on my 30 min drive to work temp never got above 150ish?
 

·
Registered
Joined
·
5,481 Posts
Discussion Starter #8
1k is about right, mine was up around 1.4k, but that is really weird about your temp IMO. Mine always gets up to 190, others would probably know if there is something wrong, but I would think it should be getting higher than that.
 

·
Super Moderator
Joined
·
11,821 Posts
Looks like your thermostat is weak and sticking open.
 

·
Registered
Joined
·
41 Posts
Yeah probably right. Im considering changing it this weekend if I get saturday off. Im going to search the forum and see if anyones done it, it will be the first time ive worked on anything that wasn't a v8.
 

·
Super Moderator
Joined
·
11,821 Posts
1 - 11 of 11 Posts
Status
Not open for further replies.
Top