Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter #1
My check engine light came on last night so I read the code today and it was the running rich/bank 1 senor 1 exhaust manifold O2 senor code. I just replaced it last year with the OEM ACdelco O2 sensor, what BS huh?
 

·
Registered
Joined
·
1,056 Posts
yeah like did the code just come on? or have you done any mods recently that would affect the sensor? cuz the sensor would be fine if its just pulling in the code and not whats causing the car to run rich
 

·
Registered
Joined
·
674 Posts
check other things first... Go through the list of why it would run rich, before fearing an O2 sensor. My Fiance's Grand Am kept throwing a P420 code and everyone knows either bad Rear O2 or bad Cat converter. Well I never thought of the TPS being faulty, but the run down of the reasons why a P420 would be thrown shows faulty TPS as the LAST thing to check. So I just let it go, then last weekend, it threw a new code for Faulty TPS (dunno the number) and when I took the TPS off to see, it was loose and sounded like parts broke inside. Threw a new on on and all is good.

Just check other sensors and parts out before fearing the O2 sensor. A diagnostic procedure is your best friend.
 

·
Registered
Joined
·
9 Posts
I agree I just got my girlfriend a cobalt LS and changed the air filter and it threw a po340 code which is a cam sensor. Come to fin out it was just some dust that got into the MAF sensor causing it. Cleaned it out and all is well.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top