Chevy Cobalt Forum banner

641 - 657 of 657 Posts

·
Registered
Joined
·
2,036 Posts
Do you have the harness you were supposed to buy? If not they don't go on with the daytime running lights only the night lights. Get some outdoor 3M double sided tape for mounting the ballasts.
 

·
Registered
Joined
·
46 Posts
Yes I have the right harness, bixenon motocontrol 9007 and the ballasts are bolted on. I'll check grounds and stuff but pls help. I'm in north east Ohio if anyone is close.
 

·
Registered
Joined
·
46 Posts
Sorry to blow up the thread but I figured it out. The stock fuses weren't strong enough. Swapped them out for 30amp ones. I just panicked because I don't have a back up vehicle. All I need to do is switch the polarity then I can get started back up.
 

·
Registered
Joined
·
2,036 Posts
If you have a harness then the stock fuses wouldn't matter at all, it only senses when the headlights are supposed to be on, off and on high beam. A harness has it's own power and ground so something is wrong...
 

·
Registered
Joined
·
922 Posts
He may have blown the fuses from not disconnecting the battery and inadvertently shorting them out. If the fuses were blown he wasn't getting the signal from the switch to the relay harness telling them to come on.

ALSO I would replace the fuses you changes with the correct amp fuse though. They are certain amps to prevent overload of power/heat that could spark a fire. Changing the fuse to higher fuse may work, but it does not protect your electrical system like it should.
 

·
Registered
Joined
·
170 Posts
I'm looking for the best place to get hid's or something similar for my fog lights to match my headlights. My headlights are blue hid with ballast and wasn't sure what I can use for my fog.

I have an 06 cobalt ss n/a 2.4l
 

·
Premium Member
Joined
·
2,635 Posts
they look berry nice, how long did it take you?
 

·
Registered
Joined
·
266 Posts
so i went on ebay to purchase some new headlights, i had stock 9007 bulbs, i tried buying some 9003/HB2 lights. Now i know HB2 and H4 are basically interchangeable, but the bulbs said they are usable in my coablt and they arent, is there any kind of adapter i can buy that is a male 9007 to a female 9003 or H4 plug?
 

·
Registered
Joined
·
22 Posts
Alright, I'm about as frustrated as a T-Rex trying to masturbate.

I've been running HIDs on all my vehicles for years now, so I'm no rookie in the department of install.

However, the Cobalt is bringing about some major issues handling HIDs.

I have a set of Optic7 Bi-Zenon 55W 6000k units with the wiring harness. The driver side fires every time. The passenger side is a whole nother story. When I turn on the headlights, the passenger side flicks on and then shuts off. I thought it was a bad ballast because the ballast would hum. Replaced the ballast, and while it doesn't hum the passenger side still flicks on and then shuts off. The grounds are good. I grounded the wiring harness to the bolt on the radiator support brace that connects to the frame. I bare metalled it as well.

Now here's the strangest part. If I turn the headlights back off, and let the car sit for a few minutes, the passenger light will fire when I turn the lights back on.

So, where's the delay in juice? What's causing the flick and what can I do to have the passenger side fire every time?
 
641 - 657 of 657 Posts
Top