Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
Hey Guys,
CEL popped up the other day. P0420. Checked the live data and the upstream O2 sensor is fluctuating as it should, but the downstream O2 sensor is fluctuating as well. Shouldn't that be constant? Car seems to be operating fine with no hesitation or misfires, and the MPG's are fine as well. I checked for exhaust leaks and couldnt seem to find any. The downpipe is a newer ZZP high flow cat with mid-length headers. everything else is stock.
 

·
Registered
Joined
·
7 Posts
Upstream O2 sensor is for the air fuel ratio. Down stream O2 is measuring the same thing but for emissions this time. Yes, this is usually constant but not perfect as stats change and cat converter gets saturated and adjustments made. If it fluctuates a lot, then it could indicate a failing cat converter. Also you won't have many symptoms like you would with the upstream o2 sensor

How have you been making out with this?
 

·
Registered
Joined
·
3,127 Posts
Upstream O2 sensor is for the air fuel ratio. Down stream O2 is measuring the same thing but for emissions this time. Yes, this is usually constant but not perfect as stats change and cat converter gets saturated and adjustments made. If it fluctuates a lot, then it could indicate a failing cat converter. Also you won't have many symptoms like you would with the upstream o2 sensor

How have you been making out with this?
The downstream failed on me and caused a 7mpg lower average. The upstream failed and caused the same thing.

Btw OP if you replace the O2 get an a.c. Delco one and save yourself a bunch of grief. Sometimes when they start failing you need to look at the freeze frame data to see. Also there's tests most professional scanners have that test the reaction time of the O2 and if it's to slow it fails
 

·
Super Moderator
Joined
·
11,821 Posts
Did you go to a wideband downstream HO² when you went with the high flow cat? If not, this code could pop up once in a while under heavy acceleration. Just cancel it and next time watch for condition of when it pops up. When you go to a high flow CAT it is normal for the downstream HO² to be jittery and less stable, just keep and eye on it and try to figure at what point it sets a code.
 

·
Registered
Joined
·
50 Posts
Discussion Starter #5
Thanks guys. Not sure if it's a wideband O2 sensor. I'll reset the code and see when it pops up again. Not sure exactly when it came on the first time. The light is still on, and I haven't really been in a rush to try to fix it as the car seems to run fine and the hwy MPG is around 28-29. I did buy an extension for the downstream O2 but haven't installed it yet. I'll keep y'all updated.
 

·
Levee
Joined
·
3,210 Posts
99% of the time the P0420 code is from a bad 02 sensor. If both are working as they should, then the Cat is usually bad. Very few times has it been something different.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top