Chevy Cobalt Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
first of all hello fellow members!
car is a 06 a/t cobalt ls with 100k on the clock.

ok so i parked my car at night and it was running fine then the next day it started freaking out.
it will not stay running and im getting a p0300 cel code.
so heres what i did so far new plugs, new ngk coil assembly, sea foam in the tank with right under a half of tank of gas, cleaned the maf and it seems to be a bit better but it still dies out when I take my foot off the gas pedal but stays running perfectly fine over 1000 RPM.

I just completely cleaned the throttle body but didn't get a chance to reinstall it because it's 20 below in Chicago lol.

But before I took the throttle body off I was checking hoses and vacuum lines and I unplugged the hose from the throttle body to the vapor canister purge solenoid and it actually stood running even though it was running rough but with it hooked up will just die out.

I'm only getting that one random misfire code and it's driving me nuts i developed some health problems so I need my car running to get back and forth to doctors and I had to cancel my appointment for today due to not having a car.

I just don't understand it was running fine the night before then in the morning it just started this issue the RPMs would fluctuate back and forth and drop really low like it wanted to stall and it did a few times but would crank right back up and be fine.

Please help I really need it right now thank you all for helping out.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
Another thing I forgot is if I hold a little gas and put it in reverse it will die out but it won't die out in drive holding the RPMs to about 1500 but we'll die out when not pressing the accelerator at all
 
1 - 2 of 2 Posts
Top