Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 15 of 15 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi folks, first off this is my first post. My 06 cobalt LS 2.2 has gremlins. A few weeks ago I was driving along everything was fine then out of nowhere power steering warning lit up, all gauges went crazy and it seemed as though the transmission disengaged. I pulled off the road, shut it off for a few minutes, started it back up and it has run great.....until today! I started the car and power steering lit up again, I started driving and the trans. wouldn't shift out of 1st ( auto. trans.) I'm not sure if it may be related or not, but every now and then when I would turn the key to ON, there would be a series of clicks under the dash. Any help will be greatly appreciated. Thank you.
P.S. sorry for such a long post.
 

·
Super Moderator
Joined
·
11,821 Posts
Try unplugging P1 and P2 from the BCM. It should clean the contacts enough for you.
 

·
Registered
Joined
·
1,522 Posts
It's inside the center console, pull off the passenger side kick panel to get to it

---------- Post added at 04:40 PM ---------- Previous post was at 04:38 PM ----------

You should probably also disconnect the battery first
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Thanks rrob5382 I will definitely disconnect the battery beforehand. I hate electrical problems enough as it is.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Hi guys, I tried all suggestions and still no change. Well, actually now the check engine light is on, power steering warning and auto-trans still staying in 1st. Something else I noticed is where the outside temp usually is next to mileage, is three blanks. I'm about ready to junk this car and buy a ford, lol. Please help.
 

·
Super Moderator
Joined
·
11,821 Posts
Did you check the power assist steering fuse? EPS fuse in underhood fuse block.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
No. I guess I didn't know that one , but that doesn't explain the trans staying in 1st gear. Or are they related in some way ?
 

·
Super Moderator
Joined
·
11,821 Posts
They are related through GMLan, never know!!!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
Ok guys, I've checked everything that has been suggested and still nothing! What else am I missing in solving this problem? I am at my wits end and can not afford bringing the car to a shop at this time. Is it possible that the ignition switch recall, which has been done, or the power steering recall, which was done in '12, have anything to do with these problems? The car never acted up prior to either of these recalls were addressed. Just saying! Thanks again for any help.
 

·
Super Moderator
Joined
·
11,821 Posts
Have you considered that maybe the steering module may have failed?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #12
Yes I have considered that, but it doesn't make sense that it would be related to the trans. not upshifting. I really hate electronically controlled systems.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #14
Yeah same here. The locks would lock/unlock by themselves, speedometer stopped reading. First time mine acted up I had my youngest son with me going 70 mph on 275 in Tampa. Scared the crap out of both of us.
 

·
Registered
Joined
·
22 Posts
Check the ground wires.
The one I had problems with was located under the driver side headlight.
The car was not turning over, a lot of rapid fire clicking from the bypass valve, dash lights flickering. I even got the power steering message.
Seems the most probable to become corroded due to its location.
Disconnect it from the body, clean it and reconnect it.
 
1 - 15 of 15 Posts
Status
Not open for further replies.
Top