Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Im going to tell the whole stor. Not sre what all is related but I figure the more info I have the more likely somebody can identify the problem.

It's an 09 LT auto Sedan w/o OnStar, base radio and no steering wheel radio controls. I bought it in January and before taking posession the dealer (small indie shop not a licensed GM dealer) they replaced the PCB for the door locks as the switches weren't working at all that fixed the driver's switch but not the passenger. It was still under warranty so I took it to a licensed dealer to have the passenger side fixed and they replaced the switch on the passenger door. The switches were now all working fine as well as the keyless remote. Just after the odometer rolling over out of warranty the cruise control stopped working. A quick google search of the problem had me disconect the battery to reset the computer which solved that but about two days later the font passenger lock wouldn't work when shifting in and out of Park while taking a trip to the store. On leaving the problem seemed to have gone away so I just ignored it. About a week later I was unable to lock or unlock the doors with the remote or the door switches. The remote still enabled/disabled the alarm and the locks still worked when shifting in and out of Park. The next day the remote worked but the switches did not. The day after everything worked. For the next couple of weeks the locks worked when shifting most of the time, but would go back and forth between the remote working and the switches working but rarely would both work at the same time. After not driving for a day everything started working again then over the next week the same thing happened starting with the remote, then the switches and now it rarely locks/unlocks when shifting as well. Trying to do some troubleshooting of my own when using the switches and remote I can hear a relay going under the center console and the switches seem to work most of the time while driving (haven't tested the remote) and when parked sometimes if I go back and forth on the door swich they will work again but it's only temporary and usually the locks stop working by the next time I drive. I tried disconneting the battery again tinking maybe since the prolems started there maybe they would stop there as well but there was no impact on the locks working. Also just today I rolled the windows down and the back passeger window seemed to stick for a moment before going, my fiance says the window has stuck on her hile se was driving a few times as well but it always eventually goes down and has no problems going back up. Not sure if it has anything to do with the locks but thought I would add it. Any help solving this would be greatly appreciated. Thanks for taking the time to read all of this and hopefully someoe out there knows exactly what I need to do to fix this.
 

·
Rocket Power
Joined
·
711 Posts
Wow...sounds like an electrical gremlin. Personally, I'd take it to a GM Dealer and have them check it out. Could be a short or a bad reflash. Maybe they can help you with a good faith warranty coverage.

Someone else here may have an idea also.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Update:
Door locks are now out completely. They don't work when shifting from park, from the remote or from the switches. Can no longer hear relay when playing with the switches except sometimes but the sound is really faint nowhere near as easily identified as it was when the issue started. Checked the fuse. It was a higher cap than what the diagram showed (25A vs 15A) but was not burned out and the link is hot when I put a test light on it. Question the first: Should the fuse be hot all the time like it is now or should there only be power on it when a switch is pressed? Question the second: If the link is supposed to be always hot where do I locate the relay for the door locks as it would be my next step in trying to track down the source of this problem?
Thanks in advance
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top