Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
first time we had this issue, it would crank but wont start.
second time it happend. it wouldnt even crank just clicking noise while the security logo blinks on. i jumped it, it started

first thing i thought of was the battery or alternator.
got both of those checked at oreilly and autozone both were Good.

just today i tried jumping it again cuz it would not start, it started but imeediatelly struggled idling then died.

second time i started it, i stepped on the throttle, and ran the rpms higher it stayed on. now it starts fine and stays on.

got the fuel pressure checked yesturday it was fine.

any suggestions? has this happend to anyone?
 

·
Super Moderator
Joined
·
11,821 Posts
Well your symptoms are those of a crankshaft position sensor going bad. But won't know for sure until you get a code or you change it.
 

·
Super Moderator
Joined
·
11,821 Posts
Doubt if it's a fuse issue, because when they burn they don't fix themselves. It could be a bad battery contact or boost post could be loose. But if you had it checked and it happens again once in a while and progressively gets worse then I would look at the crankshaft sensor. Prices vary depending on supplier.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
Ill mos def check that out. Sorry to bug, sort of a noob, but where's the boost post in the cobalts??
 

·
Super Moderator
Joined
·
11,821 Posts
No bother at all.....Under the red cap of your underhood fuseblock. Lower left in this picture..

 

·
Registered
Joined
·
18 Posts
Discussion Starter #7
k thanks!

I'll keep an update.

It's hard because not even my mechanic can diagnose this issue because when i bring it in, it starts!
 

·
Registered
Joined
·
3,127 Posts
I was thinking a loose ground possibly either on the battery or the starter.
 

·
Registered
Joined
·
3,127 Posts
I've heard of starters getting hot and no longer wanting to turn over, but i've never heard of it with a 4 cyl.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #11
hey coby7, so that fuse is the boost post?

---------- Post added at 12:38 PM ---------- Previous post was at 12:26 PM ----------

the security light turns on when this problem occurs
 

·
Registered
Joined
·
142 Posts
hey coby7, so that fuse is the boost post?

---------- Post added at 12:38 PM ---------- Previous post was at 12:26 PM ----------

the security light turns on when this problem occurs
No...the boost post is the metal post at the bottom right of the picture..it should have had a red plastic cover on it before you remove the fuse box cover

Good luck
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top