Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
i own a 2009 cobalt 2lt, its automatic(kinda pisses me off) and has roughly 10k miles on it already recently both outlets have stopped working a clicking/rattling noise comes from the dashboard when i go above 60mph and one time the traction control kicked on for no reason, anyone else having any problems or did i just get the bad one of the bunch?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
yeah im hoping cause im thinking about bringing it back to the dealer adn getting an 09 ss/tc, at a discount price of course hah
 

·
Registered
Joined
·
2,625 Posts
the outlets could be a relay/fuse(not sure which on the balt). where in the dash is the click/ rattle and is it more of a vibration(eg trim rattling)? and finally when traction kicked in, were you accelerating? (might have hit some water or something without noticing)
 

·
Registered
Joined
·
3,229 Posts
yeah im hoping cause im thinking about bringing it back to the dealer adn getting an 09 ss/tc, at a discount price of course hah
yeh bring it in for an ss/tc...hope you still have your 60day happy guarantee...if not your sh*t outta luck and even if not theres no way the dealer's gonna discount the price...

well, good luck to you on that anyways!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
yeah so i brought it back to gm and they fixed it, the rattling was actually a major problem with the power steering thats now a recall, outlets have blown twice since (after they fixed it twice)so they upgraded my wiring harness and fuses, no problems now
 

·
I cut stuff
Joined
·
6,238 Posts
wow that's crazy you must have got one of those "bad" ones. I have an 09 with 10k and no problems yet. I'm glad they fixed it for you though.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top