Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello all,

I have a 2008 Cobalt LS with basic radio, no on star or anything fancy. I was out of the country for a month and basically left my car sitting at my work and we had lots of extremely cold weather/snow and such. The problem I had as soon as i got back was that my radio does not work. The back light on the buttons will come on for a moment, and go right back off. if i hit the Information button it will display the time and if a CD is in. I can press the eject button and a CD will come out but nothing else. I had something similar to this problem before where the display was kinda scrambled and it fixed itself (this happened in cold weather as well, i assumed they were related). Now i noticed something else. when i start the car it takes like 10 seconds before i get my gas tank level/rpm reading/mileage, etc....I will get all ------------ before that info is displayed. When starting the car the ---------- will come on until the backlight on the radio is on, once the radio comes on i get my readings. I read online somewhere that all that crap is tied into a bus system (GM LAN or something). am i wrong for thinking that the car is looking for the stereo system before the readings come on, and the radio which is half working finally somewhat powers on and voila you get the readings on the dash? any help is appreciated. thanks
 

·
Super Moderator
Joined
·
11,821 Posts
Your radio might be dragging down the GMLan circuit. Try pulling the radio fuse to see if your DIC reacts differently.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top