Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey folks, I have this really weird problem where if I have my high beams on, and use my right turn signal, my headlights turn off entirely. They turn back on if I set my beams to low. It doesn't happen with low beams, and it doesn't happen with the left turn signal. Does anyone else have this problem or has anyone ever heard of this?

Thanks :)
 

·
Registered
Joined
·
3,006 Posts
Thats weird man. The good thing is you don't really need to signal if your far enough from ppl to be using your high beams.

Sorry i really can't help you..

daman added 0 Minutes and 58 Seconds later...

BTW welcome to the site!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Well normally it's not an issue, because if there are people in front of me I use my low beams, obviously. But we live on long stretches of highway and I like to signal to people behind me that I'm slowing down to turn. The first time I almost drove off the road because I wasn't expecting it to happen hahaha

I mean, now I know better so I will always switch to low beams before turning, but still....

*edit* Thanks, I had several posts when I first joined but I guess my inactivity deleted them all.
 

·
Registered
Joined
·
3,006 Posts
Well normally it's not an issue, because if there are people in front of me I use my low beams, obviously. But we live on long stretches of highway and I like to signal to people behind me that I'm slowing down to turn. The first time I almost drove off the road because I wasn't expecting it to happen hahaha

I mean, now I know better so I will always switch to low beams before turning, but still....

*edit* Thanks, I had several posts when I first joined but I guess my inactivity deleted them all.
I got ya

Yeah out data base crashed a couple of months ago and everything was lost! I had close to 3000 post
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
lol demons... Can anyone else replicate this? Or should I just bring it to the dealership?
 

·
Registered
Joined
·
575 Posts
Sounds like a circuit problem. It's sending power to the signals and diverting power from the headlights. I would take it to the dealer have em check out the harness between the headlights.
 

·
Registered
Joined
·
47 Posts
did you ever get this fixed? I have just started noticing that when I'm driving with my high beams on and then turn on the turn signal, my head lights flash off then back on. It doesnt happen on a consistent basis, so if I took it to the dealership, they would probably just chalk it up as intermittent (just guessing).
Either that or the demons have/are attacking my car now...
 

·
Sneezing Daily
Joined
·
1,155 Posts
like gibs said, I would check the circuit or even the fuse. Check for loose connections. I had something simular happen to me but I had to replace the fuse (starting to burn out). Otherwise take it to the dealership it could be the whole assembly (turn signal relay and headlights) is going and needs to be replaced
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top