Chevy Cobalt Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello,

I have a 2010 Chevy cobalt with 217,000 miles. Yesterday I drove to a local Walmart with no issues but when I got back in my car and started it, the engine started jerking and the car shut off. I barely got it started and the check engine light was on and the engine was sluggish and it felt like I had no power. I drive down the road and get onto the highway on ramp and the car would barely accelerate and it gave me the "Reduced Engine Power" message on the DIC. When that occurred, the car seemed like it was on but nothing would happen when I pressed the gas pedal. I managed to get where I needed to be, but this morning I got it started and the engine was jerking/shaking again but I was able to drive it back home without the reduced power issue but it was not shifting right at all. I noticed that it shifts at higher RPMS now and I have to baby it. I tried pressing down on the gas this morning on my way home but it's like the car doesn't have much power to it. If I baby it, the transmission shifts kinda okay but something isn't right.

Also last night I took it to Autozone and they couldn't get their OBD reader to connect to my car at all. Once I got it home this morning, it wouldn't turn over, so it's going to sit. Any idea what it might be?

Thanks!

Joe
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Timing chain so sorry

Sent from my KYOCERA-E6560 using Tapatalk
Thanks for the reply. I was hoping it wasn't that, but it would make sense. In the past my Cobalt would sometimes make a weird rattle sound when starting but it would instantly go away.
 
1 - 4 of 4 Posts
Top