Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hey all. Wifes car has been going thru coolant (maybe 2 liters every 4 months). For the last few weeks, the car has a rough idle, but only lasts about 5-25 seconds. And, in the last few weeks, the idle has been rough longer and longer. So, the other day, I pop the hood, and the coolant is low. I filled it up, and the rough idle went away...any ideas? I can't see where this car would be leaking fluid. There is never a puddle under the car in the garage....? Co:confused:nfused!
 

·
Registered
Joined
·
5,481 Posts
Check the bottom of your oil cap for a white film. This would indicate your head gasket is bad and coolant is getting into the oil. I would think you would have experienced other problems by now if that was the case but it's a start.
 

·
Super Moderator
Joined
·
11,821 Posts
Might not be leaking in the oil. I think you have a cracked head gasket leaking coolant in one of the cylinders, hense the rough idle at startup. Since coolant doesn't burn it makes your cylinder missfire until it is all ejected through the exhaust and plug dries off. Check your oil for presence of coolant. It might not be too late. If you wait too long the coolant will wash crank bearing and then you need and engine. If it missfires for more than 30 seconds it will set a code if it hasn't already. Usually cylinder #3 on the Ecotec, seems to be the weak link.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #4
The other night when we got back home, I filled up the coolant, and the rough idle went away...

I'll check to see if there is coolant in the oil tonight though.
 

·
Super Moderator
Joined
·
11,821 Posts
Don't let this problem hang around because it will bite you.
 

·
Chevy Customer Service
Joined
·
794 Posts
Interested to hear your findings, faultlessfocus. Hope all goes well tonight when you're checking into things!
Sarah
GM Customer Service
 

·
Registered
Joined
·
28 Posts
Discussion Starter #8
Well, when the car is running, I smell that sweet burning smell. I checked the oil, and I can't really tell that there is anything in it, but, there is some foamy stuff in the reservoir tank.
 

·
Super Moderator
Joined
·
11,821 Posts
Yep sure sign of a cracked head gasket.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top