Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My 08 w/ 115,000 has an RPM issue, when driving around 30 mph its real bad ,the rpm's go up and down I have a tach so I can see it goes up and down , it does also at speed around 60 mph but not as bad ,and not at all with the cruise control on.My mechanic cleaned the electric throttle body but no help.He thinks it may be the throttle body but not sure and the car isn't sending any codes .he wants $350 to change it but it looks simple to do and I can get one on e bay for $150. Maybe someone here has had the same issue and point me in the correct direction these cars seem to have the same issues ! Thanks Scott
 

·
Super Moderator
Joined
·
11,821 Posts
Not the throttle body for sure. Make sure transmission fluid levels are good.
 

·
Registered
Joined
·
266 Posts
i was reading on the interwebs again, and from what ive seen it has to do with the PCM and the TCM, the PCM needs cleared of the adaptive shift logic that the trans has learned. people often complain that it acts like the TC is trying to go in and out of the lock position.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
I just put 24 oz of lucas trans fix in and took it for a short drive and seems to have fixed the problem!!!! thanks so much $13 is better than a trip back to the shop
 

·
Super Moderator
Joined
·
11,821 Posts
So it might have just been low all along. Maybe the transmission cooling line fittings are leaking at the radiator.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top