Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
The Service Airbag and Service Tire Monitor lights keep coming on. Not always together too. Sometimes it'll be just the airbag light and sometimes it'll be the tire monitor or sometimes they show together. I would get it checked, but sometimes the lights don't even show at all. I figure a wire or something is loose or worn out. It sucks cause money is really tight right now, so I don't have really much to spend. I did just get the map sensor replaced because the traction and engine power reduced light were on and that's what the dealership said it was. It did help, but I don't know if it fully fixed it cause the problem has happened a couple times more. I sprayed electrical cleaner on all connectors because they said a harness was worn. My car hasn't done the engine power reduced or traction light since. I figured it would be connected to the lights I'm seeing now. I guess not though. Any ideas where I could look?
 

·
Registered
Joined
·
949 Posts
What year is your car?

TPMS (Tire Pressure Monitoring System) light might be coming on just because the batteries are starting to get low. Also, if you ever swapped a wheel without putting the TPMS into the new wheel, or if one of the tire pressures is vastly different than the others, etc.

Also, as @Coby7 would probably say, check the connections. They might be corroded. It'd be worth it to check the fuse box. Happen to have any other ideas, Coby?
 

·
Super Moderator
Joined
·
11,821 Posts
The SRS module and RCDLR low speed GMLan both communicate with the BCM and both modules come in on the same dark green wire. Have you tried re-seating connector C1 and C2 on the BCM?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks for the replies. I will try to look at some of this when I'm off work tonight and get back to you. It's a 2010 LT also
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top