Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter #1
So driving into a parking lot, turn a corner doing like 30 and then all of a sudden the car dings, and my airbag needs to be serviced? Everything is still plugged in, but the driverside airbag is lit up on my gauge display and the DIC says "Service Airbag".

It is under warranty to get fixed, but i have installed a aftermarket Stereo and Amps and subs, which they will say thats what at fault for the airbag.


So should I clear the code and say the hell with it?

Anybody go threw the same thing?
 

·
Registered
Joined
·
1,538 Posts
Get it serviced, and if they blame it on the stereo, i can give them the invoiced number from my car's service. Had the same issue, just driving randomly, yet my passenger side airbag notification stayed off, and the "service airbag light" came on. Turned out to be a faulty ground in the system behind the passenger side rear pillar(right behind the door). Fixed the ground, and it was fine.

The stereo has absolutely nothing to do with the airbags.
 

·
Registered
Joined
·
750 Posts
Yea i had the same problem however it was my own fault when connecting my remote amp wire into the fuse panel. I ended up grounded it out and blew a trace between the BCM and fuse box and i got the same message as well as no wipers or power steering. They fixed the trace and everything was fine. However it wasn't cheap. Ended up only costing me diagnosis fee to fix it cuz I got connections but retail was going to be over $300. FYI dont jump anything off of the wiper fuse. Use the sunroof instead
 

·
Registered
Joined
·
869 Posts
Yea i had the same problem however it was my own fault when connecting my remote amp wire into the fuse panel. I ended up grounded it out and blew a trace between the BCM and fuse box and i got the same message as well as no wipers or power steering. They fixed the trace and everything was fine. However it wasn't cheap. Ended up only costing me diagnosis fee to fix it cuz I got connections but retail was going to be over $300. FYI dont jump anything off of the wiper fuse. Use the sunroof instead
^^ Nice one.
 

·
Registered
Joined
·
4 Posts
:sad2:Well, hate to bring this subject back up but figured I throw out a few more questions on the subject. I've got a 2.2 LS Coupe, Got the lame "Service Airbag" warning as well as the passenger air bag off. Just wondering where in the wiring this issue occurs, or where else exactly to look. I tried a volt meter to the harness by the pillar next to the rear seat(passenger side). But seemed normal. I'm just tired now from workin' on my buddies car and decided to look elsewhere for help. Anything would be helpful, since I don't have the time to take my car to the dealer... :sad2:
 

·
Registered
Joined
·
69 Posts
Air Bags are nothing to **** with. I have heard of them going off (not in the cobalt) while the person was driving down the road. I am really surprised that it didn't go off. I have also heard that they don't go off in a wreck. I know what you mean on they blaming your stereo install on the problem. They blamed my DOME LIGHT problem on the aftermarket key less entry I installed. Good Luck!
 

·
Registered
Joined
·
1,538 Posts
:sad2:Well, hate to bring this subject back up but figured I throw out a few more questions on the subject. I've got a 2.2 LS Coupe, Got the lame "Service Airbag" warning as well as the passenger air bag off. Just wondering where in the wiring this issue occurs, or where else exactly to look. I tried a volt meter to the harness by the pillar next to the rear seat(passenger side). But seemed normal. I'm just tired now from workin' on my buddies car and decided to look elsewhere for help. Anything would be helpful, since I don't have the time to take my car to the dealer... :sad2:
Have you checked all the ground connections? cause they replaced the passenger seat cushion in mine, only to find out it was a bad ground wire at the bottom of the passenger side rear pillar. Check your ground wires for flaws
 

·
Registered
Joined
·
68 Posts
I spilled a bit of coffee in my passenger seat a few days ago. Right away, I wiped it up and headed to a vac station and sucked it dry. But, an hour later or so, the Service Airbag message started going off. I kept the vents pointed at the seat with the blower up high and it finally dried out. The message went away anyway.

Thought I would pass it along in case your seat got wet and you hadn't thought of that. I know 30mph sharp turns can cause cans of soda or cups of coffee to fly around :)

Good luck!
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top