Chevy Cobalt Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2010 Cobalt with auto trans, 47k miles. Normally the solenoid would click while in park when pressing the brake pedal, before shifting out of park. Lately the solenoid has been clicking when pressing the brake pedal while driving and the car has been shifting hard from 1st to 2nd and 2nd to 3rd. The problem is intermittent but is becoming more frequent within the past week. The car only shifts rough when the solenoid is clicking while driving, when it doesn?t the car shifts smooth, no problem at all. Also when this happens the cruise control will not engage. I just bought this car and it ran fine the 1st 1000 miles. I know I saw another post with same issue but there was no resolution that was in 2017 hoping someone can help me solve this problem without just throwing money and parts at it and hopefully getting the right one. Thank you.
 

·
Registered
2010 Cobalt LT 2.2L Metallic Black all stock
Joined
·
21 Posts
I have a 2010 Cobalt with auto trans, 47k miles. Normally the solenoid would click while in park when pressing the brake pedal, before shifting out of park. Lately the solenoid has been clicking when pressing the brake pedal while driving and the car has been shifting hard from 1st to 2nd and 2nd to 3rd. The problem is intermittent but is becoming more frequent within the past week. The car only shifts rough when the solenoid is clicking while driving, when it doesn?t the car shifts smooth, no problem at all. Also when this happens the cruise control will not engage. I just bought this car and it ran fine the 1st 1000 miles. I know I saw another post with same issue but there was no resolution that was in 2017 hoping someone can help me solve this problem without just throwing money and parts at it and hopefully getting the right one. Thank you.

I had an issue somewhat similar to yours. I stopped hearing the clicking that you are talking about and my cruise control wouldn't work. I noticed that my brake lights were on constantly as well. There was a part that I had to replace.. It was a pain because it is down by the brake pedal. I believe it was called the brake pedal position sensor. I am not sure what, if any, relationship there is there but that is my experience. Good luck with your fix.
 

·
Registered
Joined
·
11 Posts
I have a 2010 Cobalt with auto trans, 47k miles. Normally the solenoid would click while in park when pressing the brake pedal, before shifting out of park. Lately the solenoid has been clicking when pressing the brake pedal while driving and the car has been shifting hard from 1st to 2nd and 2nd to 3rd. The problem is intermittent but is becoming more frequent within the past week. The car only shifts rough when the solenoid is clicking while driving, when it doesn?t the car shifts smooth, no problem at all. Also when this happens the cruise control will not engage. I just bought this car and it ran fine the 1st 1000 miles. I know I saw another post with same issue but there was no resolution that was in 2017 hoping someone can help me solve this problem without just throwing money and parts at it and hopefully getting the right one. Thank you.
I recomend having a mechanic clean and repair ground 105 (G105) I had the same symptons but I did not know any better at the begining of this issue and it just grew as the grounds lost connectivity from corrosion body module,tranny module,ecm module all began to fail slowly, hope this helps.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
I recomend having a mechanic clean and repair ground 105 (G105) I had the same symptons but I did not know any better at the begining of this issue and it just grew as the grounds lost connectivity from corrosion body module,tranny module,ecm module all began to fail slowly, hope this helps.
Thank you another member had the same issue and said it was a ground as well seems to be a problem with this car. I will definitely have it looked at thanks again.
 
1 - 5 of 5 Posts
Top