Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
713 Posts
Discussion Starter #1
I just got my car out of the shop after over a month. I was rear ended and while they accepted liability and paid for my rental car, it still took about 45 days all together.

Anyways, for a few months now Ive been hearing the sound of metal vibrating on metal, almost like a bell. It seemed like my downpipe or something down there was vibrating enough when at idle that either it or something else was hitting another part and making the noise.

I ask the shop to check it out, praying they might repair it as part of the accident, but I was denied sadly. Anyway, the guy did tell me that its the "stabilizer mounts" that need to be replaced in order to fix the noise. he also mentioned theyd do it for like $150 or so.

Did he mean the lower engine mount, transmission mounts, or something else you think? I tried googling cobalt stabilizer mounts and nothing came up.
 

·
Super Moderator
Joined
·
11,821 Posts
I don't have a clue what he's talking about, he might as well have called it the gizmo or the dohickey.
 

·
Registered
Joined
·
713 Posts
Discussion Starter #3
Makes me wonder if its something as simple as tightening a loose bolt and they just want to make a few bucks for a simple job or something. Ive still not found anything along the lines of "stabilizing mount."
 

·
Super Moderator
Joined
·
11,821 Posts
Ask them for the part number

---------- Post added at 05:16 PM ---------- Previous post was at 04:47 PM ----------

Probably ment stabilizer link, better known as end-links
 

·
Registered
Joined
·
713 Posts
Discussion Starter #5
Well I drove it to work and school, and as Im about to get out of the car I see smoke coming from under the hood. I jump out and theres a puddle of coolant under the car. I open the hood and I can hear the hiss from the broken hose/cracked reservoir/broken clamp or whatever, but I also hear a weird noise coming from the engine that sounds like it might not have any coolant left in it...almost like a slight bubbling from inside the engine while its turned off....

Now I need to decide if I can fill it with water and get it home/back to the shop or if I should just wait for AAA. The shop thats had it for over a month did no repairs to the engine, so I doubt theyll be willing to cover anything...

---------- Post added at 06:33 PM ---------- Previous post was at 06:17 PM ----------

***I just remembered he mentioned something to me about a bushings kit as well.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top