Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 20 of 21 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter #1 (Edited)
so a month ago i started to notice my '10 xfe was only getting 17-18mpg 99% city driving and i have been easier on the accelerator pedal... so i decided the last two paychecks that i would go through and change fuel filter... air filter... spark plugs, so far i am back up to 22 and climbing, just under 46k miles and she is running smoother, definately noticed a difference after changing the plugs and filters as far as performance goes and she seems to have quieted down a bit more than usual... still breaking in the plugs tho.. went with ac delcos with the Iridium electrode.
 

·
Super Moderator
Joined
·
11,821 Posts
You must mean Iridium
 

·
Registered
Joined
·
79 Posts
Discussion Starter #5
no unusual vibrations, or pulls, except for when taking off, slight torque steer to the right... always adjust for that tho... I also do 99% city driving and it is less than 5 miles from where I love to where I work, commute takes 6 mins, 8 if slow traffic... and I drive from home to work and back every day.
 

·
Registered
Joined
·
278 Posts
Im getting 28 city in my 2010, running factory intake set up for now. I will put my typhoon back on after my next tire rotation and oil change. its even higher.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #8
I never launch the car, it wasn't designed for it... I let off the clutch, give it a little bit of gas and shift around 2700 RPM... and due to the short commute time, I know it gets up to 176*F as far as coolant temp goes... I normally get 20 city average... I don't shift right at 2150RPM or whenever the shift light normally comes on, because I don't want to be that person that takes 5 blocks to get up to 30mph... it is a combination of the short commute and my driving style... I believe anyways...
 

·
Registered
Joined
·
1,067 Posts
I can cruise going 67 and get 41-42...

I caught a video of the other day.. kept it stedy at 70 and my Inst. was reading 47 MPG, I got about a 3 minute long video of me driving on straight flat road.
 

·
Registered
Joined
·
15 Posts
The only time my xfe got below 30 was when the "intake camshaft position actuator solenoid" went bad. It caused a shuddering and the check engine light came on. Changing the upstream o2 sensor might also help.
 

·
Registered
Joined
·
1,067 Posts
Do a basic tune up.. air filter, change your oil / oil filter, fuel filter, cabin air filter, ect..

---------- Post added at 06:40 AM ---------- Previous post was at 06:40 AM ----------

Make sure your plugs are gapped correctly... .032 - .035
 

·
Registered
Joined
·
79 Posts
Discussion Starter #13
Do a basic tune up.. air filter, change your oil / oil filter, fuel filter, cabin air filter, ect..

---------- Post added at 06:40 AM ---------- Previous post was at 06:40 AM ----------

Make sure your plugs are gapped correctly... .032 - .035
I had already changed all of those, as well as gapped the plugs (installed brand new ac delco's in may) I hadn't considered the O2 sensor... also thinking I may have to get my fuel injectors cleaned, as far as I know they have never been cleaned thoroughly, save for the occasional fuel injector cleaner solution through the tank... changed the fuel filter, air filter, cabin air filter last wednesday, filled her up and was at 20.3mpg at that fillup... currently DIC is reading average 18.3mpg and I have been lighter on the gas pedal that previously...
 

·
Premium Member
Joined
·
3,860 Posts
If the car never gets into it's closed loop fuel tables, you'll notice poor fuel economy and performance. Since your commutes are very short, it could be that the motor never reached normal operational temperature, and thus will ignore certain sensors and run off a preprogrammed rich table.

Pull out the plugs and check for carbon buildups. That's a good sign you're running cold.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #16
my last two fuel fill ups have been averaging 21mpg city... so after breaking in the new plugs and new filters, I would say that dirty filters, and bad spark plugs were the cause of my poor mpg, 21 is what I was averaging before I noticed a drop... I enjoy the sound this LAP makes... Got the oil changed, and had it serviced yesterday... when I left the chevy dealership, I noticed that it was alot louder under acceleration than it should be... pulled the car into the shop at work and turns out the service techs at the chevy dealership forgot to completely close the air box... closed it and it is quieter... so... the oil change should help bring my mileage up as well...
 

·
Registered
Joined
·
157 Posts
Hell! The most I ever got was 23mpg since I had the car! Ha! 83,000 miles. Cali Balt! Another 10,000 to 20,000 I am redoing the dumbass fuel filter set up! Putting on out of tank fuel filter on it!!
 
1 - 20 of 21 Posts
Status
Not open for further replies.
Top