Chevy Cobalt Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
3,229 Posts
This could be a few things;
1) have you pulled your DRL (daytimerunning lights) fuse? It is under the hood in the fuse box. If it is not pulled and you have DRL's it will eventually kill the ballasts.
2) it sounds like you may have a bad ground. Check your grounds and re-ground if necessary. Don't forget to ground on bare metal (sand the metal down first)

3) One issue I had with my HID's twice was that the fuse on the relay harness was not attached well inside the fuse holder. This caused the fuse to heat up and deform and my HID's went out. I fixed it by pushing the wires in properly into the fuse holder and secured the fuse holder with zip ties. This happened to ke with both my main headlight HID harness and my fog light HID harness on separate occasions.
 

·
Registered
Joined
·
3,229 Posts
So what if I took out my day time vr unning fuse, could that solve the priblem.possyibly, currently cleaning the fuse on the relay and the fuse holder as it had a white grimey substance on it!
it may do the trick. Try that and let us know if anything changes.
 

·
Registered
Joined
·
3,229 Posts
hmm...dunno. Do they turn on at all? do they flicker, or just 1 side flickers? What brand are they? The ballasts could be shot, but it could be the bulbs too...I would need more info.
 

·
Registered
Joined
·
3,229 Posts
I'm pretty sure the ballasts are shot...or one of them is, and it's causing the other to flicker. I would say take the bulbs out and check to see if they're dark/brown/black. If not, it is probably the ballasts. DDM doesn't make the best HID's but they should last if they are ran without the DRL fuse. I would still check all your wiring and try switching with your fog light ballasts to be sure the problem is the ballasts. And then contact DDMtuning to get replacement ballasts under warranty.
 

·
Registered
Joined
·
3,229 Posts
I just put in my fog ballasts and got nothing, changed the fuse, changed the ground, im honestly dumbfounded
did you check your bulbs?



If not that, check ALL the fuses in the fuse box under the hood. Bet it's one of those that blew. Had that happen on my civic and couldn't for the life of me figure out what happened :p
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top