Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
i was driving to work today and whenever i go over bumps my radio stations change so after giving up trying to make it work right i just put in a cd and it wouldnt even work, it would just go back in forth from track number one and track number too, it wouldnt play anything. i was at work by then so i just said screw it i didnt have time to look at it more.

on my way home from work i turned my left blinker on and it started blinking very fast, very very fast. so i turned on my right blinker and it worked as it should. i started just flipping different things to see what else was going to screw up but nothing else did.

does anyone know whats wrong with my car? its a 07, i bought it used about two years ago and its been nothing but junk. im about ready to just trade it in because i cant afford to keep on fixing something new every few months. i apologise for being kind of angry but enough is enough.

if someone could please help me out here it would be great.
thanks!
 

·
Premium Member
Joined
·
11,821 Posts
Fast blinker is a burnt bulb. Do you have redondant radio controls?
 

·
Premium Member
Joined
·
11,821 Posts
Then your radio has a stuck button.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #5
how would i go about fixing that? i really hope thats all that is wrong with it because that sounds like a easy fix. i tried just hitting the side of my consel with my hand and it was still changing stations and skipping. also, what size light are my blinker lights?
thanks

---------- Post added at 06:19 AM ---------- Previous post was at 05:42 AM ----------

here is a little update. the radio, i cant get it to skip im not sure whats going on with it now but i guess if it dont skip then good enough lol

the blinkers, my driver side front blinks very fast and my driver side rear does dont blink at all. when i turn on my hazard lights my drivers side front works fine but my rear still dont work. right now i am in the process of checking the fuses.
 

·
Premium Member
Joined
·
11,821 Posts
You have a burnt tail light bulb. The fast blinking is to warn you that you have a burnt bulb otherwise you would never know. It's a 3157 I believe in the sedan anyways.

Looks like your radio button got unstuck. Soda pop is a big culprit with these when you open a can and it goes piiissssstttt!!!! One drop in the wrong spot turns to syrup turns to glue practically.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #7
i should of just looked at it and made one big update but here is another. the rear drivers side bulb was burnt out so i replaced it and all my blinkers work fine now, thats weird how it works but i think i can mark that off of my list.

my radio was messing up yesterday when my car heater was full blast and the inside of my car was kind of hot ( i work late hours and it was cold lol) anyway i thought maybe the heat was making something mess up so i let my car get a little warm but i didnt want to have to let it set for a hour to heat up all the way. i rattled all of my buttons around trying to make it mess up and still nothing.

i almost want to believe it will do it again, if it does is there anything i can do or try to see if it helps? i cant really trouble shoot it now since everything is working fine.

thanks for all the help! you are like a cobalt wizard! lol
 

·
Premium Member
Joined
·
11,821 Posts
Glad you didn't trade it in because of a burnt bulb. lol
 

·
Registered
Joined
·
72 Posts
Discussion Starter #9
i know i was just frustraded lol i replaced the fuel pump 2 weeks ago on it and it cost $270 for just that. on a side note it still isnt starting 100% like it should, it acts like theres air in the line. but it runs fine, that will have to be good enough for now untill i get time to look at it.

thanks again!
 

·
Registered
Joined
·
3,127 Posts
My gp started funny for 5 years then finally wouldn't start. Turned out to be the crank sensor. Since then its started up like a new car

Sent from my HTC Desire using AutoGuide.Com Free App
 

·
Registered
Joined
·
3,127 Posts
i did but there was no codes and every mechanic I took it too said they couldnt tell til there was a no start condition. I own my own snap on scanner so I checked it religiously too
 

·
Registered
Joined
·
72 Posts
Discussion Starter #13
how much does the sensor cost and is it hard to change? im not having much luck finding out what is wrong with mine either, if its cheap maybe it would be worth it.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top