Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
It's weird this only happens when my car has been sitting out in the sun for at least an hour or so. Other than that everything's fine. When I start up the engine it sounds normal for about 3 seconds and then it will make a loud clicking sound that sounds like a diesel engine for about 2 seconds. Then the engine will jerk for a split second. Is this all just because it's hot outside? Like the oil thinning out maybe? It's around 90-100 degrees everyday where I live.
 

·
Registered
Joined
·
144 Posts
I have the same problem with my car, was actually going to start a thread about it and see if anyone had the same thing, mine is basically everytime I start it and GM still can't diagnose the problem, they told me it was the starter staying engaged and replaced that, still the problem is there. I was also told it was the oil pump, which doesn't make sense at all, and another thing I was told is that it might be the starter solenoid. Unfortunately GM won't replace anything unless one of the tech's there hears it, and whenever they have the car, no noise, well so i'm told anyway
 

·
Say What again!
Joined
·
6,036 Posts
Take a video of it.
 

·
Registered
Joined
·
144 Posts
Yeah I should do that, i've got a half decent camera for my ZX9, it should do the trick, i'll do that this weekend when i'm not working
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top